Page MenuHomePhabricator

insource:"A, B et C (Le Prisonnier)" should match interwiki links such as [[fr:A, B et C (Le Prisonnier)]]
Closed, ResolvedPublic

Description

Plain-text insource search should match interwiki links, but it doesn't when the prefix is omitted in the query.

Compare:
https://en.wikipedia.org/w/index.php?title=Special%3ASearch&profile=default& search=insource%3A%22A%2C+B+et+C+%28Le+Prisonnier%29%22&fulltext=Searchs&rbackend=CirrusSearch
https://en.wikipedia.org/w/index.php?title=Special%3ASearch&profile=default&search=insource%3A%22fr%3AA%2C+B+et+C+%28Le+Prisonnier%29%22&fulltext=Search&srbackend=CirrusSearch


Version: unspecified
Severity: normal

Details

Reference
bz72902

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:59 AM
bzimport added a project: CirrusSearch.
bzimport set Reference to bz72902.
bzimport added a subscriber: Unknown Object (MLST).
whym created this task.Nov 3 2014, 2:40 PM

Confirmed. It should indeed.

bd808 edited projects, added Discovery; removed MediaWiki-Core-Team.Apr 7 2015, 4:56 PM
Manybubbles moved this task from Needs triage to Search on the Discovery board.May 7 2015, 8:00 PM
demon removed a subscriber: demon.Aug 19 2015, 3:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 19 2015, 3:56 PM
Deskana lowered the priority of this task from Normal to Lowest.Dec 31 2015, 3:48 AM
EBernhardson closed this task as Resolved.Nov 2 2016, 9:49 PM
EBernhardson claimed this task.
EBernhardson added a subscriber: EBernhardson.

This now works as intended

Restricted Application added a project: Discovery-Search. · View Herald TranscriptNov 2 2016, 9:49 PM