Page MenuHomePhabricator

Cache bug in IE with MsCatSelect extension
Closed, ResolvedPublic

Description

  1. Install MsCatSelect (https://www.mediawiki.org/wiki/Extension:MsCatSelect)
  2. Open the wiki with IE 9, 10 or 11.
  3. Edit a page with 2 or more categories.
  4. Uncheck one category from the checklist introduced by MsCatSelect and save.
  5. Edit the page again.
  6. Notice how the category just removed appears again, as if the last edit wasn't saved. However, if you clear the cache (by refreshing for example) the category is gone.

My speculation is that IE is caching parts of the interface that it shouldn't be. I played with $wgCachePages and other cache settings to try to prevent client-side caching, but the bug persists. This may be a IE bug, rather than a MediaWiki or MsCatSelect bug, because in Chrome and Firefox it doesn't happen. Also, if you switch to IE debug mode then the bug disappears, which further supports the idea that IE is caching things it shouldn't, as the debug mode probably disables caching.

However, here is the strangest part: SmartK and me tried to reproduce this bug in two wikis, both with IE 11. I was able to reproduce it in only one wiki, while SmartK was able to reproduce it in both! The only apparent differences between the wikis is that the one where I COULD reproduce the bug had PHP 5.3 and a https domain, while the other had PHP 5.4 and a http domain. But again, SmartK could reproduce the bug in BOTH wikis. So really, I don't know where the bug comes from. This is a very erratic bug, the only clear thing is that it's IE and cache related, but more testing is needed to pin down the cause.

Small update: We think this bug was introduced with MediaWiki 1.21 or 1.22. We still have it today in stable MW 1.24 but could not reproduce it in MW 1.25. Maybe this helps...

Can someone else take a look? It's a very annoying bug for MsCatSelect, and would be great if it could be fixed somehow, even if IE is to blame.

Event Timeline

Sophivorus raised the priority of this task from to Medium.
Sophivorus updated the task description. (Show Details)
Sophivorus changed Security from none to None.
Sophivorus added a subscriber: SmartK.
SmartK added a comment.Dec 2 2014, 1:13 PM

Same problem with IE11 (just tested with Windows 8.1)

Sophivorus updated the task description. (Show Details)Dec 2 2014, 1:16 PM
Sophivorus updated the task description. (Show Details)
Sophivorus updated the task description. (Show Details)
Sophivorus added a subscriber: Sophivorus.

Hi, did you report this to the maintainers of https://www.mediawiki.org/wiki/Extension:MsCatSelect already (or bring it up on the talk page)?
I don't see any mention of a bugtracker on their extension wikipage so I'm not convinced they look into phabricator.wikimedia.org.

Aklapper lowered the priority of this task from Medium to Lowest.Dec 2 2014, 1:28 PM
SmartK added a comment.Dec 2 2014, 1:28 PM

Hello Aklappert, yes as we are the maintainers ;-)

Sophivorus renamed this task from Cache bug in IE 9 and 10 with MsCatSelect extension to Cache bug in IE with MsCatSelect extension.Dec 2 2014, 2:08 PM
Sophivorus updated the task description. (Show Details)
Sophivorus updated the task description. (Show Details)Dec 2 2014, 2:15 PM
Sophivorus updated the task description. (Show Details)Dec 2 2014, 2:20 PM

Hello Aklappert, yes as we are the maintainers ;-)

Oha! :) Sorry. In that case, would you like to have a dedicated project in Phabricator maybe, that you could watch and get notified of, instead of being in the clumsy "Other extensions" bin? Please see https://www.mediawiki.org/wiki/Phabricator/Creating_and_renaming_projects - let's follow up in a dedicated separate task if you're interested. Cheers!

SmartK added a comment.Dec 3 2014, 3:24 PM

Ok, I will talk to Felipe. I think it is a great idea and hopefully we will go this way...

SmartK updated the task description. (Show Details)Dec 3 2014, 3:27 PM
SmartK added a comment.Dec 8 2014, 1:32 PM

Thank you Andre!

SmartK updated the task description. (Show Details)Dec 9 2014, 2:59 PM
Wmat added a subscriber: Wmat.Jan 14 2015, 4:58 PM

This bug basically makes MsCatSelect unusable for me. I've recently added hundreds of new Categories in a hierarchy of subcategories and NONE of them are available to the User via MsCatSelect :(

Wmat added a comment.Jan 15 2015, 6:03 PM

I've updated my wiki to master, upgraded MsCatSelect to master and this problem is still present. I've tried various browsers, cleared browser caches, tried private/incognito browsing and the problem persists.

So you've experienced the bug under every condition? Do you conclude that it isn't IE nor cache related?

Wmat added a comment.Jan 16 2015, 2:28 AM

Yes, I think it's related to https://phabricator.wikimedia.org/T44938 somehow

SmartK closed this task as Resolved.Jul 22 2018, 10:49 AM
SmartK claimed this task.

I did not notice this problem in the recent versions anymore. I think we can close this now!