Page MenuHomePhabricator

Enable autopatrolling and patrolling user rights on Wikispecies
Closed, ResolvedPublic

Description

After discussions within Wikispecies several admins support that we should request start use patrol rights in order to reduce the workload of new page patrollers, and less yellow-marked new pages.

We also request that sysops should have the ability to grant and revoke the user right.

Here's the link to the discussion:
https://species.wikimedia.org/wiki/Wikispecies:Village_Pump#Patrolled_and_autopatrolled_users

Event Timeline

Dan_Koehl updated the task description. (Show Details)
Dan_Koehl raised the priority of this task from to Normal.
Dan_Koehl added a subscriber: Dan_Koehl.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 10 2015, 4:36 PM

Change 192103 had a related patch set uploaded (by Odder):
Enable recent changes patrolling on Wikispecies

https://gerrit.wikimedia.org/r/192103

Patch-For-Review

tomasz added a subscriber: tomasz.Feb 21 2015, 9:50 PM

Change 192103 merged by jenkins-bot:
Enable recent changes patrolling on Wikispecies

https://gerrit.wikimedia.org/r/192103

demon closed this task as Resolved.Feb 23 2015, 5:28 PM
demon claimed this task.

It sounds like its now active and working?

Yes, the feature is now live. https://species.wikimedia.org/wiki/Special:ListGroupRights reports two new user groups.

Wikispecies admins should now be able to add users to, and remove them from, both of them, as well as to patrol edits made by users who are not automatically autopatrolled.

I tried it out with three users, I gave those three users both autopatrolled and patrolled rights, and it seems to work very well, for their newly created pages, but the pages they made before are still yellow, which I gather is fully correct.

So I wish to thank you for your kind help and assistance, since it will make the work easier for Wikispecies admins.

For what it's worth, you only need to add users to the patroller user group if you want them to have the ability to have their own edits marked as patrolled and the ability to patrol other users' edits.

(It kind of follows the logic that if one is trusted/experienced enough to patrol other people's edits, then one's edits will automatically be marked as patrolled, too.)

Glad to be of assistence, best of luck.

Thanks tomasz, one more question, as for the autopatrolled, I guess this is a n automatic function, where and how is that function configured? Can we do it within the community, or shall we ask someone else?

@Dan_Koehl: I'm not sure I follow… Can you describe more broadly what you're asking?

These new user groups are defined in a configuration file, so any and all changes will need to be requested here, on Phabricator; there's unfortunately no way of changing them through on-wiki interface at this time.

tomasz set Security to None.

Sorry Thomas, I was confused, and refered to autopatrolled as a function which could be autimatically granted fter a speciified time, which is of course not the case. (I mixed up the term "auto" as if it was automaticall given after a certain time)

The autopatrolled and patrolled user rights have now been implemented on Wikispecies, and already resulted in a better control of the articles. SteinsplitterBot has also been in evaluation use for a couple of days.

https://species.wikimedia.org/wiki/Wikispecies:Autopatrollers

But so far, only a few users actually performed any patrolling.

So I have question, which I hope I ask on correct place, othervice, pleaes fell free to move it to a relevant place:

Reading through https://species.wikimedia.org/wiki/Special:Log/patrol, is there any way to filter the autopatrolled changes, to enable an easier way to see who and when actually performed a true patrol activity?

A second question, maybe off Topic, as a project with a growing number of editors, but less advanced users countering vandalism, would confirmed and autoconfirmed user rights be helpful and suitable for Wikispecies, or is this a user right that is slowly being faded out on the Wikimedia projects?

As for now, I do see a logic in a user right between newly registered users/IP adresses, and users who has made a number of edits, but still, for some reasons should not be given autopatrolled rights.

Greatful for your input on those issues.

And thanks a lot for the help so far, Wikispecies is growing, and will need to be upgraded on the administration side, since many longtime users and admins, are biology researchers with less experience from wikipedia and other projects where counter vandalsim activities are more developed ,