Page MenuHomePhabricator

When editing post as wikitext, result is returned as wikitext, so can't be correctly re-rendered.
Closed, ResolvedPublic

Description

I used the wikitext editor to edit a post. The edit succeeds, but it doesn't return it in the right format, so it doesn't correctly re-render.

The request is

It is returned as:

You can see that it's returning wikitext (the same format as the input from the editor). It should be returned fixed HTML, since the edit is done, and we're now going to normal view mode.

The database/cache write itself is fine AFAICT, and a page reload will show everything normally again.

This is probably caused by the recent format refactoring, and is currently on Beta: http://en.wikipedia.beta.wmflabs.org/wiki/Talk:Flow .

Event Timeline

Mattflaschen-WMF raised the priority of this task from to Unbreak Now!.
Mattflaschen-WMF updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2015, 10:01 PM

Change 203819 had a related patch set uploaded (by Matthias Mullie):
Stop requiring render data from POST APIs

https://gerrit.wikimedia.org/r/203819

Change 203820 had a related patch set uploaded (by Matthias Mullie):
Make submitTopicTitle use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203820

Change 203821 had a related patch set uploaded (by Matthias Mullie):
Make newTopic use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203821

Change 203822 had a related patch set uploaded (by Matthias Mullie):
Make lockTopic use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203822

Change 203823 had a related patch set uploaded (by Matthias Mullie):
Stop submitHeader from needing submit-API output

https://gerrit.wikimedia.org/r/203823

This was caused by changing 'contentFormat' param to 'format', because 'format' is also used for output format (or default to storage format)
Previously, those APIs didn't accept 'format' either, so we just returned default (usually storage format, I think)

Anyway, proper fix here IMO is to stop letting write APIs output render data: we (now) have read APIs that have all available info. That's what all above patches do.

Change 203819 merged by jenkins-bot:
Stop requiring render data from POST APIs

https://gerrit.wikimedia.org/r/203819

Change 203820 merged by jenkins-bot:
Make submitTopicTitle use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203820

Change 203821 merged by jenkins-bot:
Make newTopic use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203821

Change 203822 merged by jenkins-bot:
Make lockTopic use _flowBoardComponentRefreshTopic

https://gerrit.wikimedia.org/r/203822

Change 203823 merged by jenkins-bot:
Stop submitHeader from needing submit-API output

https://gerrit.wikimedia.org/r/203823

DannyH closed this task as Resolved.Apr 16 2015, 6:18 PM