Page MenuHomePhabricator

Previews are not always generated immediately after uploading a file to Wikimedia Commons
Closed, ResolvedPublic

Description

After uploading a file to Commons, a preview should be generated and displayed. However, the preview generation often fails, and no image is shown after upload (see attached screenshot).

Event Timeline

Mike_Peel raised the priority of this task from to Needs Triage.
Mike_Peel updated the task description. (Show Details)
Mike_Peel added a project: Commons.
Mike_Peel added a subscriber: Mike_Peel.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 24 2015, 8:33 PM

Steinsplitter moved this task from Incoming to Uploading on the Commons board.Apr 25 2015, 6:36 AM
Aklapper added a comment.EditedApr 27 2015, 3:16 PM

Does this only happen with PDF files? "often fails" - do you have more example files?

I don't know if it happens with PDF files or not: my example was of a JPG. Apologies for the confusion caused by the screenshot being a PDF!

"Often fails" - it's happened with around 50% of the files I've been uploading in the last week or so (a sample of a few hundred).

https://commons.wikimedia.org/wiki/File:Beaumaris_Castle_2015_012.jpg displays a thumbnail preview for me so I cannot reproduce.
What are other examples?
Or maybe the problem just happens right after uploading and the thumbnail creation service is "just a bit slow"?

"Or maybe the problem just happens right after uploading and the thumbnail creation service is "just a bit slow"?" - yes, this is probably the issue. The images all show up fine a short time after uploading, but they weren't showing up on the page you see after the upload has been done ~50% of the time.

Aklapper renamed this task from Previews are not generated after uploading a file to Wikimedia Commons to Previews are not always generated immediately after uploading a file to Wikimedia Commons.Jun 15 2015, 12:46 PM
Aklapper triaged this task as Lowest priority.
Aklapper set Security to None.
jijiki closed this task as Resolved.Feb 22 2019, 8:08 PM
jijiki claimed this task.
jijiki added a project: Thumbor.
jijiki added a subscriber: jijiki.

Please reopen if this is still an issue