beta-scap-eqiad broken since June 3rd 5:24am UTC
Closed, ResolvedPublic

Description

beta-scap-eqiad broke https://integration.wikimedia.org/ci/job/beta-scap-eqiad/55583/console

05:24:20 05:24:21 Finished mw-update-l10n (duration: 00m 05s)
05:24:20 05:24:21 Unhandled error:
05:24:20 Traceback (most recent call last):
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/cli.py", line 276, in run
05:24:20     exit_status = app.main(extra_args)
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/main.py", line 39, in main
05:24:20     self._before_cluster_sync()
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/main.py", line 218, in _before_cluster_sync
05:24:20     version, wikidb, self.verbose, self.config)
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/tasks.py", line 512, in update_localization_cache
05:24:20     force=force_rebuild, quiet=quiet_rebuild)
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/tasks.py", line 428, in _call_rebuildLocalisationCache
05:24:20     logger)
05:24:20   File "/mnt/srv/deployment/scap/scap/scap/utils.py", line 310, in sudo_check_call
05:24:20     raise subprocess.CalledProcessError(proc.returncode, cmd)
05:24:20 CalledProcessError: Command '/usr/local/bin/mwscript rebuildLocalisationCache.php --wiki="eowiki" --outdir="/tmp/scap_l10n_852230964" --threads=2   --quiet' returned non-zero exit status 255
05:24:20 05:24:21 scap failed: CalledProcessError Command '/usr/local/bin/mwscript rebuildLocalisationCache.php --wiki="eowiki" --outdir="/tmp/scap_l10n_852230964" --threads=2   --quiet' returned non-zero exit status 255 (duration: 00m 10s)

Looking in https://logstash-beta.wmflabs.org/ the scap log bucket has:

Fatal error: Class 'Raven_Client' not found in /mnt/srv/mediawiki-staging/php-master/extensions/Sentry/SentryHooks.php on line 73
hashar created this task.Jun 3 2015, 12:00 PM
hashar updated the task description. (Show Details)
hashar raised the priority of this task from to Needs Triage.
hashar added a subscriber: hashar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 3 2015, 12:00 PM

That is caused by https://gerrit.wikimedia.org/r/#/c/213469/ (Add PHP error logging to Sentry extension) for T85188.

It introduces a PHP dependency for raven/raven in composer.json which provides Raven_Client. mediawiki/vendor has not been updated though and I guess a test to assert Raven_Client can actually be loaded would be nice.

Change 215606 had a related patch set uploaded (by Hashar):
Revert "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/215606

Change 215606 merged by Hashar:
Revert "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/215606

hashar triaged this task as Unbreak Now! priority.Jun 3 2015, 12:15 PM
hashar set Security to None.
hashar closed this task as Resolved.
hashar claimed this task.

I have reverted the Sentry patch and commented about it on T85188

Triggered a build of beta-code-update-eqiad and scap managed to complete ( https://integration.wikimedia.org/ci/job/beta-scap-eqiad/55630/console ).

Change 216753 had a related patch set uploaded (by Gergő Tisza):
Re-apply "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/216753

Change 216753 merged by jenkins-bot:
Re-apply "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/216753

Restricted Application added a subscriber: Luke081515. · View Herald TranscriptJul 6 2015, 5:53 PM

Change 223510 had a related patch set uploaded (by Gergő Tisza):
Re-apply "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/223510

Change 223510 merged by jenkins-bot:
Re-apply "Add PHP error logging to Sentry extension"

https://gerrit.wikimedia.org/r/223510