Page MenuHomePhabricator

Run ruby2.0lint instead of ruby1.9.3lint
Closed, ResolvedPublic

Description

I have took a look and looks like all repositories except oojs/ui use ruby 1.9.3 for syntax check. (See T1361 for the list of repositories and ruby versions.) Upgrade all repositories to ruby 2.0. As far as I know, there is no reason to use ruby 1.9.3.

Event Timeline

zeljkofilipin claimed this task.
zeljkofilipin raised the priority of this task from to Normal.
zeljkofilipin updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 11 2015, 3:07 PM

Change 237680 had a related patch set uploaded (by Zfilipin):
WIP Run ruby2.0lint instead of ruby1.9.3lint

https://gerrit.wikimedia.org/r/237680

Change 237680 merged by jenkins-bot:
Run ruby2.0lint instead of ruby1.9.3lint

https://gerrit.wikimedia.org/r/237680

JanZerebecki closed this task as Resolved.Sep 29 2015, 7:45 PM
JanZerebecki added a subscriber: JanZerebecki.