Page MenuHomePhabricator

Close icon in notification icon displaced in stable on desktop screens
Closed, ResolvedPublic

Description

Embarrassingly the close icon is misplaced on tablets:

Let's fix this for next week. I doubt we'll make the SWAT window this afternoon.

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterDo not apply max-width to notifications overlay

Event Timeline

Jdlrobson raised the priority of this task from to High.
Jdlrobson updated the task description. (Show Details)
Jdlrobson moved this task to To Do on the Reading-Web-Sprint-56-Four Lions board.
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2015, 10:11 PM
phuedx added a subscriber: phuedx.Sep 18 2015, 9:43 AM

Interestingly, I see the following on enwiki in stable:

and nothing out of the ordinary in beta.

Yup I now see this too.
Seems like some caching issue.
The issue is that hacky -1em we use all over the place:

.overlay-header .cancel {
    /* left: -1em; */
Jdlrobson moved this task from To Do to Doing on the Reading-Web-Sprint-56-Four Lions board.

Change 239519 had a related patch set uploaded (by Jdlrobson):
Do not apply max-width to notifications overlay

https://gerrit.wikimedia.org/r/239519

@Jdlrobson: I don't see this locally or on BC any more and so I can't verify 239519. I'm tempted to move this to Ready for Signoff with a reminder to check enwiki on Tuesday.

So it seems like I was mistaken. This kicks in for desktop. Try 1882px for example. (You can zoom out on your browser to mimic this)

Jdlrobson renamed this task from Close icon in notification icon displaced in stable to Close icon in notification icon displaced in stable on desktop screens .Sep 21 2015, 5:32 PM
Jdlrobson set Security to None.

Change 239519 merged by jenkins-bot:
Do not apply max-width to notifications overlay

https://gerrit.wikimedia.org/r/239519

phuedx closed this task as Resolved.Sep 23 2015, 8:14 AM

Verified on BC.