Problem creating an account at https://discourse.wmflabs.org/
Closed, DeclinedPublic

Description

As a Wikimedia I want to sign up an account at https://discourse.wmflabs.org/ so that I can join the discussion.

Someone mailed me "Hey! I couldn't open an account. Do you know what's the problem?"

AdHuikeshoven updated the task description. (Show Details)
AdHuikeshoven raised the priority of this task from to Needs Triage.
AdHuikeshoven added a project: VPS-Projects.
Steko added a comment.Jan 28 2016, 6:50 PM

Ideally discourse.wmflabs.org should be working with Wikimedia single-signon (SSO) credentials, apart from the specific problem listed here. Detailed instructions are here and I don't think it should be difficult. This way users could sign in with their Wikimedia credentials. What do you think?

Ideally discourse.wmflabs.org should be working with Wikimedia single-signon (SSO) credentials, apart from the specific problem listed here. Detailed instructions are here and I don't think it should be difficult. This way users could sign in with their Wikimedia credentials. What do you think?

Yes that would be ideal, please see T124691. Having trouble opening an account is a separate issue, which isn't diagnozed fully yet.

It looks lie SSO won't just be some configuration, it will require some engineering effort. I can look into what caused the failure to create an account, but need more details about the failure. To start off with, what step did the failure occur at, and what was the indication that it failed? Were there any error messages?

Rillke added a subscriber: Rillke.Mar 18 2016, 2:09 PM

I like how many tools use oAuth for login. It just takes me a click and I am logged-in.

Aklapper changed the task status from Open to Stalled.Aug 22 2017, 11:27 AM

@AdHuikeshoven: Can you provide more information?:

I can look into what caused the failure to create an account, but need more details about the failure. To start off with, what step did the failure occur at, and what was the indication that it failed? Were there any error messages?

Setting task status to "stalled" as I cannot reproduce. After registering I got

You're almost done! We sent an activation mail to xxxx@example.com. Please follow the instructions in the email to activate your account.
If it doesn't arrive, check your spam folder, or try to log in again to send another activation mail.

I clicked that link and got

Welcome to Wikimedia Discourse!
[ Click here to activate your account ]

After I clicked I got redirected to https://discourse.wmflabs.org/top/all

Hence seems to work?

Aklapper closed this task as Declined.Sep 14 2017, 8:59 PM

@AdHuikeshoven: Can you provide more information?

Unfortunately closing this report as no further information has been provided.

@AdHuikeshoven: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!