integration-slave-precise-1011.eqiad.wmflabs has not run puppet since Jan 25
Closed, ResolvedPublic

Description

km@km-tp ~> ssh integration-slave-precise-1011.eqiad.wmflabs 
Linux integration-slave-precise-1011 3.2.0-75-virtual #110-Ubuntu SMP Tue Dec 16 19:24:01 UTC 2014 x86_64
Ubuntu 12.04.5 LTS
integration-slave-precise-1011 is a Puppet client of integration-puppetmaster.eqiad.wmflabs (puppetclient)
integration-slave-precise-1011 is a CI Jenkins slave for browser tests (role::ci::slave::browsertests)
integration-slave-precise-1011 is a CI Jenkins slave on labs (role::ci::slave::labs)
integration-slave-precise-1011 is a CI Jenkins slave for running tests in local browsers (role::ci::slave::localbrowser)
The last Puppet run was at Mon Jan 25 15:06:56 UTC 2016 (10651 minutes ago).

This is causing random test failures because the slave-scripts repo is out of date. I'm going to depool it.

Legoktm created this task.Feb 2 2016, 12:40 AM
Legoktm updated the task description. (Show Details)
Legoktm raised the priority of this task from to Unbreak Now!.
Legoktm added a subscriber: Legoktm.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2016, 12:40 AM
hashar closed this task as Resolved.Feb 2 2016, 8:47 AM
hashar claimed this task.
hashar added a subscriber: hashar.

Puppet in /var/log/puppet.log yells about: Server hostname 'integration-puppetmaster.eqiad.wmflabs' did not match server certificate;

For some reason /etc/puppet/puppet.conf hostname entries are missing .integration. in their fully qualified domain name :-/ The file got last changed on Jan 25 15:07.

I have fixed it, ran puppet again and:

Contint::Slave_scripts/Git::Clone[jenkins CI slave scripts]/Exec[git_submodule_update_jenkins CI slave scripts]: Triggered 'refresh' from 1 events

I have reenabled the slave in Jenkins.