Page MenuHomePhabricator

Rework the #Beta-Cluster-Infrastructure workboard
Closed, ResolvedPublic

Description

Reasoning

  1. tracking "in-progress" in multiple places is hard and the fewer places we do it the better. I've seen in-progress tracked well in team-specific "sprint" or "kanban" boards instead.
  2. Categorizing tasks by type...
    • makes it easy to see where a lot of tech debt lives (or where processes/tooling should be improved, at least)
    • helps new comers to get involved
    • encourages more active triaging into those categories (easier to do and more reward than just making the huge backlog column even huger)
    • and, it more manageable than a single big "backlog" (and to-triage) column

Proposal

(based on trying to categorize all of the current tasks in my head)

  • To Triage (default)
  • EPICs / Tracking
  • Backlog (general) - general column, could be broken up more later if we need to (or other columns merged into it if they don't seem useful in practice)
  • On wiki change - no code changes/deploys needed
  • Extension and Services deploys - deploying/enabling new extensions and/or services on Beta Cluster
    • combined extensions and services because A) there aren't that many tasks to be unwieldy and B) they should both have the same level of awareness
  • CI or CD related - changes to how Beta works to better support Continuous Integration or Continuous Deployment practices
    • This may come later
  • Tag

Event Timeline

greg created this task.Jun 28 2016, 10:20 PM
Restricted Application added a subscriber: Zppix. · View Herald TranscriptJun 28 2016, 10:20 PM

Where would system-level things like puppet issues fall?

greg added a comment.Jun 28 2016, 10:54 PM

Where would system-level things like puppet issues fall?

General, unless you think it deserves its own breakout? (and unless it fits in with the "Services" column)

Where would system-level things like puppet issues fall?

General, unless you think it deserves its own breakout? (and unless it fits in with the "Services" column)

I'm not sure, I was wondering if maybe it was intended to go into the services column. Looking at the current workboard we only have about 12 tasks mentioning puppet so it might not need it's own column.

greg added a comment.Jun 28 2016, 10:58 PM

Yeah, eg T72792: Set up puppet exported resources to collect ssh host keys for beta isn't really services specific, more general beta cluster tech debt (is how I'm thinking about things)

greg moved this task from INBOX to Backlog on the Release-Engineering-Team board.Jun 30 2016, 6:19 PM
greg updated the task description. (Show Details)Aug 4 2016, 11:24 PM
greg updated the task description. (Show Details)Aug 5 2016, 8:46 PM
greg closed this task as Resolved.Aug 5 2016, 9:02 PM
greg claimed this task.

{{done}} except for the CI/CD column which may come later.

Sorry for the spam.

greg moved this task from Backlog to Done on the User-greg board.Aug 5 2016, 9:14 PM