Page MenuHomePhabricator

abusefilter-modify should let you view histories of private filters
Closed, ResolvedPublic

Description

I am an abuse filter editor on frwiki (i.e. I am in a group that gives me the abusefilter-modify right), but I can no longer view the history of private filters.

I believe this is a regression caused by the patch for T126129: now, only users with the abusefilter-view-private can view the history of private filters. According to the description the abusefilter-view-private right given in T21362, abusefilter-modify was supposed to be a superset of abusefilter-view-private (note that users with abusefilter-modify can still view and edit private filters).

Event Timeline

Orlodrim created this task.Aug 18 2016, 9:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 18 2016, 9:16 PM

Change 305584 had a related patch set uploaded (by Platonides):
Let abusefilter-modify users see history of hidden filters

https://gerrit.wikimedia.org/r/305584

Thanks for the details, Orlodrim. It indeed seems to be the culprit. The above patch should fix it.

Change 305584 merged by jenkins-bot:
Let abusefilter-modify users see history of hidden filters

https://gerrit.wikimedia.org/r/305584

Change 305596 had a related patch set uploaded (by Legoktm):
Let abusefilter-modify users see history of hidden filters

https://gerrit.wikimedia.org/r/305596

Change 305596 merged by jenkins-bot:
Let abusefilter-modify users see history of hidden filters

https://gerrit.wikimedia.org/r/305596

Mentioned in SAL [2016-08-22T23:58:18Z] <dereckson@tin> Synchronized php-1.28.0-wmf.15/extensions/AbuseFilter/Views/: Let abusefilter-modify users see history of hidden filters ([[gerrit:305596]]+[[gerrit:306077]], T143365) (duration: 00m 50s)

Platonides closed this task as Resolved.Aug 23 2016, 12:03 AM
Platonides claimed this task.

It has just been fixed,