Page MenuHomePhabricator

Entity Suggester shows double information at certain moments
Closed, ResolvedPublic

Description

At certain moments, the information displayed in the entity suggester is doubled:

https://www.wikidata.org/wiki/Q2537692

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 23 2016, 9:00 AM
hoo claimed this task.Aug 24 2016, 11:23 PM
hoo added a project: Patch-For-Review.
hoo added a subscriber: hoo.

Patch: https://github.com/Wikidata-lib/PropertySuggester/pull/175

The cause here is that we do the search for suggestions whenever the property input field is empty and gets focused. As it gets focused twice whenever a new statement is added, we load the suggestions twice and (due to a race condition) even sometimes display them twice. The fix for this is simple: Only load the suggestions one the very first focus, the base suggester will then do the right things for us, when the field's value changes.

thiemowmde triaged this task as Low priority.Aug 26 2016, 1:52 PM
thiemowmde moved this task from Proposed to Review on the Wikidata-Sprint-2016-08-16 board.
thiemowmde moved this task from incoming to in progress on the Wikidata board.
thiemowmde added subscribers: thiemowmde, Jonas.
thiemowmde closed this task as Resolved.Aug 31 2016, 4:15 PM
thiemowmde moved this task from Review to Done on the Wikidata-Sprint-2016-08-30 board.