Page MenuHomePhabricator

Autoconfirmed user able to delete page [id.wikipedia]
Closed, InvalidPublic

Description

There is a case when an autoconfirmed user moved a page ("H2") to an existing redirect page ("H2 (manga)"), the redirect page is logged as being deleted. Is this behavior intended or is this a bug?

P.S. The tag "Rang [1.0.1]" is attached to that log. I'm not sure why it got there, but this OAuth application is written by me, hosted at Tool Labs, and is intended for helping image deletions in idwiki (mainly used by me only, and I don't advertise it to anyone; so it's unlikely that anyone else uses this application). This may or may not be related to the case above.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2016, 3:09 PM
Tgr closed this task as Invalid.Aug 30 2016, 4:53 PM
Tgr added a subscriber: Tgr.

This is the intended behavior, see Help:Redirect#Moving_a_page and T106119.