Page MenuHomePhabricator

Cite RefToolbar: Templates dropdown not displaying due to RTD's syntax highlighter gadget
Closed, DeclinedPublic

Description

Editing on both a Mac & PC, using Chrome. When editing using WikiMarkup, the Cite toolbar (RefToolbar) Templates dropdown is not displaying. In the Advanced tab, the Style selection dropdowns are also not displaying.

Would be grateful to have this functionality back, as I use the Cite Template dropdown constantly while editing.

This is a conflict between the RefToolbar gadget and Remember the dot's syntax highlighter gadget. Reason is not known.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 15 2016, 3:07 PM
BrillLyle added a comment.EditedSep 15 2016, 3:18 PM

Screenshots to show display issues. If I click on the sliver of white at the top I will get the first Template option (web). I need all 4... :-) Thx! - Erika

Hi @BrillLyle, thanks for taking the time to report this!
Could you please open your web browser's developer tools and reload the page on which you see the problem, but with &debug=true added to the address of the page?
If there is a problem or an error with JavaScript (for example some gadget), it should be printed in the 'console' of the developer tools. For more information please see:

Hi @Aklapper -- I am on the Tools, Elements and have even selected the code where the dropdown is highlighted. The Console tab is empty / not populated. Suggestions?

Is there a way for me to send you the direct point that is the problem?

Best,

– Erika

Please let me know if I'm doing something wrong.

This is the link

No output on the console, okay...
I cannot reproduce the problem here in Firefox - the refToolbar gadget is enabled and the Cite stuff opens. :(

@Aklapper -- Ugh. I would use Firefox but it locks up my computer. Has no one else complained about this?

I have had this happen before if my memory serves. Last night I did the purge (time clock gadget) and refresh which seems to have worked on my Mac last night but today on the PC it's not having it at all....

I can't really edit -- I'm very dependent on the RefToolbar and I am a compulsive cite person. No other solutions, eh?

– Erika

I did notice recently that when I load the edit page I see the link symbol cycle cycle from fat to not fat, and the Cite button is often delayed in loading as well. I haven't seen this recently, and it seems like it might be somehow connected, possibly?

@Aklapper -- Hey I just tried logging OUT of Wikipedia and the dropdown menu works in Chrome! Why would it do that?!?

It also works (either logged on or logged out) in Firefox. Blargh.

– Erika

Hmm, your https://en.wikipedia.org/wiki/User:BrillLyle/common.css is empty, okay.

If you disabled any other gadgets on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-gadgets except for refToolbar does the problem still happen?

@Aklapper -- Hey I just tried logging OUT of Wikipedia and the dropdown menu works in Chrome! Why would it do that?!?
It also works (either logged on or logged out) in Firefox. Blargh.

Oh, that means you cannot reproduce the problem anymore? :)

@Aklapper -- No I continue to face the same problem. And switching to Firefox is not a good enough solution. Is there an update on the timeframe that this can be fixed. It's really affecting my ability to edit Wikipedia effectively.

Thanks,

– Erika

Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Sep 19 2016, 8:37 PM

Can you try T145787#2645544 ? After that I run out of ideas.

@Aklapper

  • I don't know what that code means, what action item I should take
  • I find it hard to believe that this is not fixable. This is fundamental functionality to use the WikiMarkup citation templates. I don't understand the delay and I am concerned at the lack of what seems to be concern about such an important loss of functionality.

Please advise.

– Erika

I already tried turning on and off the RefToolbar Cite gadget.

Please let me know what can be done. I want to have this escalated and addressed as soon as possible. I can't edit right now without doing manual citations. It's very bad.

– Erika

Izno added a subscriber: Izno.EditedSep 20 2016, 5:23 PM

I already tried turning on and off the RefToolbar Cite gadget.

Aklapper wants you to turn off other gadgets (either completely or one by one) until the issue goes away, since, as is usually the case with the kind of issue you are experiencing, another gadget may be interfering.

I find it hard to believe that this is not fixable.

We cannot fix an issue if we do not understand the cause of it. Saying "I have a problem" does not help us understand the cause. Only troubleshooting does that. Aklapper has been a little opaque, but not particularly so, in his attempts to troubleshoot the issue with you. However, he is not familiar with every wiki's configuration of gadgets, so I might advise that you go to the technical village pump of your wiki (for en.wp, that is WP:VPT) and open a section there to see if someone can help you, if you try the above and see no improvement.

This is fundamental functionality to use the WikiMarkup citation templates. I don't understand the delay and I am concerned at the lack of what seems to be concern about such an important loss of functionality.

This is one of many issues. Many issues cause loss of functionality. Until a fix can be identified (see above) or the functionality is seen to be so key, and without any other work around, the wiki would not work, most issues are monitored and fixed only as routine. As there are multiple workarounds for this problem (including a different browser; using the citation templates manually; and not using templates, among others), while you may feel the problem is urgent... it basically isn't.

Agtx added a subscriber: Agtx.Sep 22 2016, 12:45 AM

I'm having the same issue, which was resolved when I disabled syntax highlighter. Some kind of interaction between the two gadgets is causing a problem in Chrome.

@Agtx -- You are brilliant! That was the problem. I posted on the syntax highlighter discussion page as well as updated the RefToolbar discussion page. I love me my syntax highlighter but I can turn it off if for now if it means I can use the Cite menus. Thank you so much!!!

Erika

Aklapper renamed this task from Cite RefToolbar - Templates dropdown not displaying to Cite RefToolbar: Templates dropdown not displaying due to SyntaxHighlighter.Sep 22 2016, 2:10 PM
Aklapper added a project: SyntaxHighlight.

@Aklapper Based on Agtx's comment, he is probably referring to the syntax highlighter gadget. I have removed SyntaxHighlight as a result.

Izno renamed this task from Cite RefToolbar: Templates dropdown not displaying due to SyntaxHighlighter to Cite RefToolbar: Templates dropdown not displaying due to RTD's syntax highlighter gadget.Sep 22 2016, 2:40 PM
Izno updated the task description. (Show Details)

True, thanks for correcting!

Izno moved this task from Defect backlog to External on the Cite board.Jul 20 2017, 10:18 PM
Izno closed this task as Declined.Apr 9 2019, 5:47 PM

This is not core software problem, in Cite or otherwise. The incompatibility is in the gadget. (It has other known incompatibilities.)