Page MenuHomePhabricator

unknown change in "autoreviewer " permission in Arwiki
Closed, InvalidPublic

Description

Autoreviewer according to the local policy and comunity final discussion in 2013 : the user who his revisions will automatically marked as accepted (sighted) if the page is stable (no pending revisions), and their new pages not patrolled (appear as yellow in (Special:Newpages).

one month ago, some admins found the autoreviewer's new pages automatically marked as patrolled, this is big issue because the autoreviewers don't have enough experience yet, and their new pages need to revision.

We don't know how it changed, but we need to change back the configuration in arwiki and make their pages not auto-patrolled (as a local policy), thanks.

Event Timeline

Restricted Application added subscribers: JEumerus, Matanya, Aklapper. · View Herald TranscriptSep 18 2016, 12:01 AM
Ibrahim.ID updated the task description. (Show Details)Sep 18 2016, 2:41 AM
Urbanecm added a subscriber: Urbanecm.EditedSep 18 2016, 8:14 AM

Currently only sysops and bots has autopatrolled right. You can check it yourself at https://ar.wikipedia.org/wiki/خاص:عرض_صلاحيات_المجموعات .

So this must happened at all wikis by change in the code of FlaggedRevs. And it give sense because autoreview means "any new revisions made by the user are automatically marked as sighted". For page creation a new revision is needed so it's marked as accepted too. And if it can be marked as accepted in FlaggedRevs why it can't be marked as patrolled in list which is in MediaWiki core?

So there wasn't any arwiki specific change, autoreviewer still has only autoreview permission.

thank you for your respond.
I think this is big mistake from FlaggedRevs team , because that is different between "autoreviewer" and "autoptrolled", new pages must not treat like edits.

anyway, is there is any technical solution ?

So could you list all the usergroups who should have the autopatrolled right?

Fascinating is that enwiki has autoreview permission in autoconfirmed group (and there is no extra autopatrol right). But my sandbox which I've created a moment ago (https://en.wikipedia.org/wiki/User:Martin_Urbanec/sandbox) wasn't marked as patrolled automatically. Maybe this is because enwiki doesn't apply FlaggedRevs to all pages but arwiki does. I can't find out why it does this because I have no autoreview permission at arwiki.

@Dereckson Because there was no change in arwiki permission setting in givven time and the state changed a month ago I guess bots and sysops (current state). But from some reason

Urbanecm changed the task status from Open to Stalled.Oct 9 2016, 11:03 AM

Waiting till reply at T145946#2665391 will be posted.

Urbanecm triaged this task as Low priority.Oct 9 2016, 11:04 AM
Urbanecm added a project: User-Urbanecm.
Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.
Urbanecm lowered the priority of this task from Low to Lowest.Oct 10 2016, 11:50 AM

No change could be made if we don't know what we should do.

Any update here?

Urbanecm closed this task as Invalid.Nov 18 2016, 1:06 PM

We can't do unknown thing.

Meno25 removed a subscriber: Meno25.Apr 30 2019, 11:41 AM
Restricted Application added a subscriber: alanajjar. · View Herald TranscriptApr 30 2019, 11:41 AM