Page MenuHomePhabricator

Populated redlinked categories should have a Related Changes link in the toolbox
Closed, ResolvedPublic

Description

With categories, the "Related changes" link displays changes to the pages categorized in the category, not to links in the category source. This means that a populated category (category with at least one member) should have this link, even if it's red-linked.

Steps to reproduce:

  1. Go to Special:WantedCategories
  2. Pick a category without description page (red link) and members, like Category:Wikipedians who are not a Wikipedian
  3. On the sidebar, observe that under the group "tools" (where there's a "what links here" link), there's no "Related changes" link. Note that any category with associated description page has that link.
  4. This link should exist also on categories that have members even if the category description page does not exist, because it's functional. See for example Changes related to Category:Wikipedians who are not a Wikipedian.

Event Timeline

OdMishehu created this task.Oct 9 2016, 6:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 9 2016, 6:46 PM

Hi @OdMishehu, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem, please add a more complete description to this report. Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 9 2016, 7:00 PM

I've improved the description. This looks like a pretty easy bug to fix

Shanikae added a subscriber: Shanikae.EditedJan 27 2017, 2:10 AM

Hi,
I would like to tackle this issue.
Since I am new to the community could someone guide me in reproducing the issue?

Hi
I have fixed this issue.

Could you please assign it to me. And please guide me how to PR?

Could you please assign it to me.

You should be able to do this from the comment box on Phabricator: Add Action...Assign/ClaimSubmit

And please guide me how to PR?

We use Gerrit for code review. If you're comfortable with using Gerrit you can head to the Getting started page to set yourself up. Otherwise, I'd recommend going through the longer tutorial.

Change 334499 had a related patch set uploaded (by Shanikae):
Add Related Changes Link for all categories

https://gerrit.wikimedia.org/r/334499

Shanikae claimed this task.Jan 27 2017, 6:50 AM

Change 334499 merged by jenkins-bot:
Add Related Changes Link for all categories

https://gerrit.wikimedia.org/r/334499

Ciencia_Al_Poder closed this task as Resolved.Jan 28 2017, 10:27 AM