Page MenuHomePhabricator

Old English Wikipedia (angwiki) reports good redirects as broken redirects
Closed, ResolvedPublic

Description

https://ang.wikipedia.org/wiki/Syndrig:BrokenRedirects shows a lot of pages as broken redirects, but they do work. Probably an issue with namespace configuration.

Event Timeline

Restricted Application added subscribers: JEumerus, Matanya, Aklapper. · View Herald TranscriptNov 24 2016, 7:28 PM
MarcoAurelio triaged this task as Low priority.Nov 24 2016, 7:28 PM
MarcoAurelio added a comment.EditedNov 25 2016, 10:44 AM

angwiki has a lot of namespace aliases defined, that might be the cause. Ideas:

  • Run checkBadRedirects.php, and/or
  • Run namespaceDupes.php

Mentioned in SAL (#wikimedia-operations) [2016-11-26T13:36:24Z] <Krenair> ran refreshLinks on angwiki for T151584, it ran into issues with the EventBus extension at the links tables step

krenair@terbium:~$ mwscript refreshLinks.php angwiki
Refreshing redirects table.
Starting from page_id 1 of 18186.
[...]
Refreshing links tables.
Starting from page_id 1 of 18186.
Fatal error: Call to a member function getId() on a non-object in /srv/mediawiki/php-1.29.0-wmf.3/extensions/EventBus/EventBus.hooks.php on line 668
TTO closed this task as Resolved.Jan 13 2017, 8:24 AM
TTO assigned this task to Krenair.
TTO added a subscriber: TTO.

Seems this was fixed by the first part of the maintenance script (Refreshing redirects table.). The few redirects currently listed at BrokenRedirects at angwiki are indeed broken.

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptAug 21 2017, 1:10 PM