Wikipedia portal: update eventlogging for sister project clickthroughs
Closed, ResolvedPublic4 Story Points

Description

Currently, on the portal dashboard, we only show that a clickthrough happened on one of the sister projects, but not which one.

I'd like to have a breakdown of the clickthroughs by sister project to aid in discovering if the order of the list of sister project should be changed or additional future work.

debt created this task.Dec 7 2016, 5:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 7 2016, 5:56 PM
debt triaged this task as "Normal" priority.Dec 7 2016, 5:56 PM
debt assigned this task to chelsyx.Dec 15 2016, 9:18 PM

This will be a good one for Chelsy to do because adding a new metric module ('report") will give her a chance to get better acquainted with the new way we're generating datasets using the Reportupdater framework.

mpopov claimed this task.EditedDec 15 2016, 9:42 PM
mpopov set the point value for this task to 4.

Whoops :/ I had a brain toot and FORGOT THE THING I LITERALLY JUST WROTE and added this to the big migration patch anyway. Sorry!

Edit: I guess that shows how easy to is to add new metrics under the new system :)

Change 325870 had a related patch set uploaded (by Bearloga):
Migrate to Reportupdater framework

https://gerrit.wikimedia.org/r/325870

Change 336350 had a related patch set uploaded (by Bearloga):
Point to new datasets & add new metrics

https://gerrit.wikimedia.org/r/336350

Change 336350 merged by Bearloga:
Point to new datasets & add new metrics

https://gerrit.wikimedia.org/r/336350

debt added a comment.Feb 8 2017, 4:21 PM

Nicely done - one comment: can the scale on the left hand side be a lighter color in order to more easily see what the numbers are? :)

mpopov added a comment.EditedFeb 8 2017, 7:49 PM

@debt: the dark axes is a known bug that we can't reproduce / don't know what causes it :\ if you click on a different dashboard and then go back to the sister projects one, it should be white

debt added a comment.Feb 9 2017, 1:25 AM

ahhh...nevermind then! ;)

Change 325870 merged by Bearloga:
[wikimedia/discovery/golden] Migrate to Reportupdater framework

https://gerrit.wikimedia.org/r/325870

if the order of the list of sister project should be changed

Note that the general rule is that the order follows the usage of the projects (the pageviews as shown on WikiStats, historically).

debt closed this task as "Resolved".Thu, Mar 16, 12:35 PM