Page MenuHomePhabricator

Page curation creates double page headings on user talk pages
Closed, ResolvedPublic

Description

Steps to Reproduce:

  1. Go to Special:NewPagesFeed on en.wikipedia.org
  2. Click a page to review
  3. Click tag and then select a tag
  4. Write a comment to the page creator.
  5. Click "Add 1 Selected Tag"

This has also been verified when tagging for deletion via BLP PROD.

Actual Results: The user talk page of the page creator receives a message with double headings
Expected Results: The user talk page of the page creator receives a message with only one heading.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 10 2017, 6:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This looks like https://gerrit.wikimedia.org/r/#/c/311856/
"We'll have to coordinate the deployment of the code with the new template content." - oops?

Hm. Without a doubt, though, the issue has been troublesome to message
receivers and off-putting to curators recently. I appreciate your looking
into it.

JustBerry triaged this task as High priority.Jan 19 2017, 4:51 AM

Upping priority per relatively wide impact of the bug, considering this is the official Mediawiki page curation tool.

The only production wiki where this is deployed is English Wikipedia hence I do not see any justified urgency here.

@JustBerry: As you raised the priority of this task, do you plan to write a patch?
Asking as resources of teams are limited when it comes to working on requests. We want to be realistic about communicating what is being worked on, to maximize the impact of changes. Practically, this often unfortunately means assigning a low priority to many tasks.
If the priority was increased because you plan to work on this task please claim the task by setting yourself as assignee. Thank you for your help!

This looks like https://gerrit.wikimedia.org/r/#/c/311856/
"We'll have to coordinate the deployment of the code with the new template content." - oops?

Yeah, sorry about this. I just have to import the XML content.

@Aklapper The English Wikipedia has quite a lot of articles created (and hence pages being curated) relative to other wikis. However, I understand limitations in the team's resources. Thank you for claiming the task, @Mattflaschen-WMF.

Just as an FYI, its getting more reports are coming in on the page curation talk page. I'm sure its the same bug, but just putting it here as an FYI: https://en.wikipedia.org/w/index.php?title=Wikipedia_talk%3APage_Curation&type=revision&diff=761417151&oldid=761182075

@Etonkovidova, reminder to check into this one (no hurry).

I've imported NewPagesFeed_Templates.xml into English Wikipedia, which fixes most of them. Unfortunately, there are some conflicting edits that will have to be cleaned up manually (people edited after the dump export time), e.g. https://en.wikipedia.org/w/index.php?title=Template:Nothanks-sd-NPF&action=history.

I'll loop through to find these.

Do you have anything more constructive than 'Ewww'? This was the simplest solution and didn't cause any issues (that goes for the username as well).

I did exactly what I said I was going to do on multiple occasions:

You had several days when you were familiar with this task and could easily have seen all of the above, especially the last two.

@Mattflaschen-WMF, thanks for resolving the issue. The initial issue seems to be resolved on my end now.

JustBerry lowered the priority of this task from High to Normal.Jan 26 2017, 7:04 AM

Changing task priority back to normal per the main issue getting resolved. Not marking as closed yet per task being moved to "QA Review." Will leave closing to @Mattflaschen-WMF and/or QA reviewers.

Mattflaschen-WMF raised the priority of this task from Normal to High.Jan 26 2017, 3:00 PM

You're welcome. Completing the task does not affect the priority, so I've set it back to High.

Do you have anything more constructive than 'Ewww'? This was the simplest solution and didn't cause any issues (that goes for the username as well).

There were several better solutions, but it's a bit late to discuss those now.

Checked in betalabs and selectively in testwiki.

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Jan 31 2017, 6:53 PM