Page MenuHomePhabricator

Ideation: Games and Students Contests
Closed, ResolvedPublic

Description

Session title

Ideation: Games and Students Contests

Main topic

How to grow our technical community

Type of activity

Unconference session

Etherpad

https://etherpad.wikimedia.org/p/devsummit17-games-contests

Description



=== 1. The problem ===
This session aims to spark discussion and ideas around two topics:
1. The creation of games and gamified experiences based on the mechanics and dynamics of the Wikimedia Projects.
2. The creation of student (or professional) coding contests focused on creating tools for easing the use (both for editors and users) of the Wikimedia Projects.

Both topics try to tackle the following issues:
Getting new people involved with the Wikimedia Projects.
To develop useful and fun "tools" for veteran users.
How to spark motivation on developers to create innovative stuff around the WM Projects.

=== 2. Expected outcome ===
* Sharing of ideas and current projects realted to the mentioned topics.
* General feedback for ideas presented around both topics.

=== 3. Current status of the discussion ===
N/A.

=== 4. Links ===
N/A

== Proposed by ==
@Racso

== Preferred group size ==
10

== Any supplies that you would need to run the session ==
Projector.

== Interested attendees (sign up below) ==

# Add your name here

-----

Quick copy & paste of Etherpad content:
=================
SESSION OVERVIEW
=================

Title: Games and students contests. By: Racso

Day & Time: Tuesday 11:00 am – 12:10 pm

Room:Chapel Hill

Phabricator Task Link:

Facilitator(s): Oscar (Racso)

Note-Taker(s): Qgil (thanks!)

Remote Moderator:

Advocate:

SESSION SUMMARY
=================

Purpose: [Enter session goal]

Agenda:
e.g:
10 minutes: Introduction
30 minutes: Discuss problems
15 minutes: Discuss potential solutions to problems
5 minutes: Conclusion

Style:
Choose one of:
* Problem-solving: surveying many possible solutions

Topics for discussion:
* Games that use some dynamics of Wikimedia projects
* Contests for creating tools for the Wikimedia Projects


Chronology: [Capture the gist of who said what, in what order. A transcript isn't necessary, but it's useful to capture the important points made by speakers as they happen]

We start with introductions (please add yoursef):
* Oscar (WMCO), Professor at UPB Bucaramanga
* Alex Pico (WikiPathways)
* Qgil (WMF), Technical Collaboration team.
* Anders Riutta, WikiPathways
* Amir Aharoni (WMF)
* Francisco (WMF)
* Trizek (WMF)
* Aklapper (WMF)

== Games that use some dynamics of Wikimedia projects ==

Wikimedia Adventure and example, but ideas for projects more attractive to people. We need more editors, yes, but other people don't want to edit but would still contribute in other ways it would be appealing to them.

For instance, Vandalism. What do you think about that experience?

French Wikipedia has a tool that has had that sentence when loading: "search and destroy". For a lot of people fighting vandalism is actually kind of a game. Destroy vandals as fast as you can. The problem is that you may "destroy" many "innocent contributors" (contributors who add content in good faith, but their contributions could look like vandalism, maybe because they are new to WP) by mistake. We want to be friendly to and encourage new contributors, so this is possibly not a good area?

Oscar explains that he contributed fighting vandalism and considered it "fun". It had some aspects of a game. (Mention to a presentation in Wikimania about "Wikipedia is a game", link http://www.raphkoster.com/games/presentations/wikipedia-is-a-game/).

Enjoyment has been lost because too many reasons:
* Community hostile to newcomers.
* Easy tasks and easy enjoyment tasks are gone. Years ago you could start the article about Circle, or other basic things. Now it's more difficult, and most tasks are more specialized. (comment that this is not correct in smaller languages)

For instance, what about process all the vandalism already reverted, and create a tool / pool for learning.

Oscar demoes a basic prototype game in his laptop presenting new edits and evaluating whether they are vandalism or not. This would happen with a pool of edits, not the actual Wikimedia database. The game might show that a person is learning to detect vandalism effectively. Gamify the onboarding/training process for new editors.

Oscar explains that he would like to get closer to videogames in order to find ways to contribute. In this case, imagine that after some "offline" evaluations correct, you gain some reputation, and at some point you start getting presented real cases. Imagine that then the system would give points to the person who evaluates correctly the vandalism, the expert user who assesses that evaluation, and so forth.

Time for ideas, either about this game or other ideas from other people:

Anders: the idea of having the games as "documentation", something external to Wikimedia, is interesting,

The basics of that game could go into other areas: i.e. quality edits. Turns out that games can be also good mobile UIs.

WikiPathways Academy example:
Stand-alone site: wikipathways.github.io/academy (SGL integrates this as a component)
Code: https://www.github.com/wikipathways/academy/
The same activities that are done on WikiPathways wiki (for example, see http://www.wikipathways.org/index.php?title=Special:CurationTags&showPathwaysFor=Curation%3AUnderConstruction) are shown wrapped in sciencegamelab.org (SGL) framework, which gives scores and other gamification elements to the same actions.

Problematic principles:
* Trying to convert everybody to editors. Editing is not for everybody.
* Trying to develop everything ijn MediaWiki. Also hard and not always the best option.

Francisco: experience in OpenStreetMap. Gamification is catching up. Two tools:
* HumanitarianOSM: every time a hurricane or something distorts the space, the tool offers ways to identify places where the map is different and updating the information after the events, in a way easy for newcomers.
* Map roulette, identifies areas where data might be not very good. Assigns areas to people based on (some algorithm?)

Mention to Unvisited app in Android, for finding articles needing pictures wherever you are, in a range of N km.

Translations. How to connect this with mobile and the habit to type in mobile for Facebook, Messenger, etc. Imagine editing from one of these services to an article. For instance, translations of short strings. A prototype made at the Jerusalem Hackathon by Amir. https://github.com/amire80/mediawiki-telegram-bot

Why is that tool not in production? Amir: because I am busy with many things... The code is there, someone shoud fix a couple of bugs, problems with identification and security to be fixed.

Duolingo is an example of gamified language learning. The app offers Wikipedia translation opportunities for advanced users via the Duolingo interface. Guessing that the content is copy/pasted from/to app and Wikipedia.

Very small contributions is key. Very difficult to find small contributions.

Beyond Wikipedia: Wikivoyage, add a hotel. Describe and categorize an image.

Wikidata Game is a good example of small, quick tasks: http://tools.wmflabs.org/wikidata-game/#

Idea: within a Commons category, present two pictures and ask, which pic is nicer? Imagine that that would help prioritization of search results.


== Contests ==

Have you ever been in a game jam? They give you a topic and you have to develop a game about that topic.

Oscar organized WikiDev Challenge, a 24h contest. FIXME URL. The topic was attribution. People not attributing Commons images used in their documents i.e. "Source: Wikipedia".

Tools to ease attribution. The challenge didn't happen yet; will be done in Jan or Feb.

(Related: proposal to organize a Wikimedia Developer Contest: https://phabricator.wikimedia.org/T147545 )

Important to find a clear mission and the basic technical documentation so they can get to work quickly.

Event Timeline

Racso created this task.Jan 10 2017, 8:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 10 2017, 8:49 PM
Racso updated the task description. (Show Details)Jan 10 2017, 8:52 PM
Qgil awarded a token.Jan 10 2017, 11:51 PM
Qgil added a subscriber: Qgil.

@Racso is there anything else remaining in this task or are you planning to use this space for further discussion? If not, I would close this task as resolved!

Aklapper closed this task as Resolved.Mar 22 2017, 10:35 PM

@Racso is there anything else remaining in this task or are you planning to use this space for further discussion? If not, I would close this task as resolved!

No reply, hence assuming this task is resolved. Please reopen if not. :)