Page MenuHomePhabricator

Kartographer maplink/mapframe ExternalData should render all geolines and/or geoshapes in an OSM relation regardless of continuity or whatever it is (it's not working properly, basically)
Closed, DuplicatePublic

Description

I've tried making a few maplinks calling OSM data for Wikidata items (Danube, Nile, Amazon, Aire and Yosemite Natl Park) for demonstration purposes on Wikidata. Only one of them (Yosemite) works properly. None of the rivers render with geoline, for some reason (there was one OSM way which rendered for the Danube map but was superfluously tagged with wikidata=Q1653; I removed it per OSM guidelines).

In addition, I've tried rendering Kam Sheung Road Station with Kartographer using both geoline and geoshape, but nothing happens.

Event Timeline

Jc86035 created this task.Jan 22 2017, 7:29 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 22 2017, 7:29 AM
Jc86035 updated the task description. (Show Details)Jan 22 2017, 7:31 AM

I wonder if the explanation for geoline exemples not working is T155924.

Same problem here: T154599

I think we can merge these two tickets.

Jc86035 closed this task as Resolved.Jan 25 2017, 10:17 AM
Jc86035 claimed this task.

Duplicate of T154599.