Page MenuHomePhabricator

http://korma.wmflabs.org/ got erased
Closed, DeclinedPublic

Description

...which blocks me from sending a "latest patches by new contributors to review" email. :)

Event Timeline

Aklapper triaged this task as High priority.Jan 25 2017, 1:39 PM
Aklapper created this task.

@Paladox: No. "korma.wmflabs.org will be deprecated" is not "korma.wmflabs.org has been deprecated". Please read carefully.

@Aklapper Hi! Yes, unfortunately it looks like the instance that hosts korma.wmflabs.org got deleted as in T143349#2969456. Do let us know if we can help in anyway to restore this service - if you happen to have the source code for the app, we can look into how we can set up a new instance and get it back up.

Aklapper renamed this task from http://korma.wmflabs.org/ is down: "502 Bad Gateway" to http://korma.wmflabs.org/ got erased.Jan 30 2017, 10:57 AM
Aklapper claimed this task.
Lcanasdiaz added a comment.EditedJan 31 2017, 2:07 PM

@Aklapper if we want to recover the legacy Bitergia dashboard what we have to do is:

That should be all to bring korma back to life.

UPDATE:

  • in the meantime and in order to have the data asap you can even do it in your personal machine
  • I've just did it in a url like "http://localhost/wmf/" creating a link from /var/www/html/wmf to my cloned repo
  • it won't work if you try to open the index.html file directly from the directory due to the paths
Aklapper closed this task as Declined.Feb 8 2017, 4:21 PM

Thanks Luis for the explanation / how-to!

I've decided that we should not spend time fixing this (will not re-set up the legacy korma.wmflabs.org) and instead put efforts into fixing data regressions (see T137997: Visualization/data regressions after moving from korma.wmflabs.org to wikimedia.biterg.io and the priorities of its open task dependencies) that we have in the new Kibana version, with a deadline on end of March when data that is currently missing in Kibana but was available in korma is presented to WMF management as part of WMF's quarterly check-ins.
If that time span (8 weeks) is too short, Luis explained how we could work around getting that data. Or we might have to live with some data missing for one quarter.