Page MenuHomePhabricator

mediawiki.org DNS TXT entry for Google Search Console site verification
Closed, ResolvedPublic

Description

This is a request for the noc@wikimedia.org Google account to use the Add a property feature in Search Console (https://www.google.com/webmasters/tools/home?hl=en) with the Alternate methods - DNS option to add https://mediawiki.org, then use the Manage property option to add abaso@wikimedia.org as a Full user (i.e., delegated access). abaso@wikimedia.org will then use this to link up the MediaWiki YouTube channel and look at Search Console reports on mediawiki.org and subdomains.

https://gerrit.wikimedia.org/r/#/q/owner:%22Dr0ptp4kt+%253Cabaso%2540wikimedia.org%253E%22+project:operations/dns shows an example of how this was done previously for wikipedia.org and subdomains.

@dr0ptp4kt is happy to try to coordinate this over a Hangout.

Event Timeline

Restricted Application added a project: Traffic. · View Herald TranscriptMar 24 2017, 9:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Dzahn added a subscriber: Dzahn.Mar 28 2017, 12:45 AM

It looks like the mediawiki.org zone in DNS already has a TXT record for Google verification:

600 IN TXT  "google-site-verification=SB70h2VwbTUOmrd3YTPxnT4gjjX5u_g8MAxkIaCW03c"

Are you saying that needs to be changed? Does this need a real DNS change or just actions in web ui with the noc@ Google account?

Dzahn triaged this task as Medium priority.Mar 28 2017, 12:46 AM
ema moved this task from Triage to Watching on the Traffic board.Mar 28 2017, 9:38 AM

Oh! In that case it is *probably* just actions done with the noc@ account to delegate "full" access to abaso@wikimedia.org to https://mediawiki.org (which should authorize subdomains, too) from https://www.google.com/web masters).

@Dzahn does Google Search Console for noc@ show that the site verification code matches what's already in DNS like you communicated here? If so, I think the next step would just be to delegate full access to abaso@wikimedia.org

Dzahn added a comment.Apr 5 2017, 3:51 PM

@dr0ptp4kt I don't really see the code but it has a green check box next to "DNS".

I gave full access to abaso@wikimedia.org for https://mediawiki.org. There are also separate properties for http:// and www. variants but hopefully they are not needed since the existing one covers all?)

Also note an existing owner you share full access with is "searchteam+gwt@wikimedia.org". Do you know who that is and if it's still active?

Bummer, it looks like that didn't do it. Would you please check the noc@ email to see if there's a site verification request that you can approve for associating the YouTube channel for MediaWiki? Failing that, I think I may need to in fact request an update to DNS (I can submit a patch if we absolutely need to do so).

The searchteam group appears to have one member, @Deskana. I believe that's still active, but best if Dan speaks to it.

Dzahn added a comment.Apr 5 2017, 4:07 PM

I don't really know how to check noc@wikimedia.org email. If i try to login with the credentials i have on mail, i get the " Add Gmail to your Google Account " dialog.

Also note an existing owner you share full access with is "searchteam+gwt@wikimedia.org". Do you know who that is and if it's still active?

Yep, that's me! For a while we thought the data in Google Webmaster Tools might be useful to the Search Team, but in the end that wasn't the case. The data analysts don't use that account any more... as evidenced by the fact I am apparently the only member of the group. ;-)

Dzahn added a comment.Apr 5 2017, 4:09 PM

checking the "messages" in Search Console itself, the last one is from 4/1/17.

Dzahn added a comment.Apr 5 2017, 4:14 PM

@dr0ptp4kt I also added you http://mediawiki.org, https://www.mediawiki.org and https://www.mediawiki.org with Full access.. any difference now?

@Deskana ok, thanks i removed the unused account (from those 4 properties where i added abaso@)

Dzahn added a comment.Apr 5 2017, 11:56 PM

re: mail to noc@ I was stupid of course i can check that, it's just an alias for root@ and all ops get that. but .. i can still not see one from Search Console earlier today.

@Dzahn, no luck for me. So when you're at "https://www.google.com/webmasters/tools/home?hl=en" does it say "No new messages or recent critical issues." under all of the *mediawiki.org URLs?

I think it may be easiest if we do a Hangout to troubleshoot if there's nothing in Search Console that you can approve. Calendar up-to-date?

Dzahn added a comment.Apr 6 2017, 5:20 PM

@dr0ptp4kt So you are saying even though i gave you full access to the domain(s) you can't read the associated messages? That seems strange, the whole point of delegating access is that you can read that and act on it, isn't it? I can definitely confirm it says "abaso@" and "full" access. And there are lots of messages including some who want to associate a Youtube channel, just none look legitimate or from you. I would really prefer and find it easier if we can keep using the ticket. It's also better for the next person to see what we did.


http://mediawiki.org/
Website
Recent messages

https://mediawiki.org/
Website

No new messages or recent critical issues.

http://www.mediawiki.org/
Website
Recent messages

https://www.mediawiki.org/
Website
Recent messages

Dzahn added a comment.Apr 6 2017, 5:22 PM

@Dzahn, no luck for me.

What went wrong? Did it say "permission denied" or something? What was the error please.

Dzahn added a comment.Apr 6 2017, 5:24 PM

@dr0ptp4kt Is this the one you want to approve? " mediawiki-0794@pages.plusgoogle.com would like to associate his YouTube channel MediaWiki to your website https://www.mediawiki.org/" That's under "View messages for https://www.mediawiki.org/" but not for the other URL combinations.

@Dzahn, I can review pageview trends, but the console isn't showing me any approval messages to authorize the "MediaWiki" YouTube channel to associate it with https://mediawiki.org/. Are you able to share here the details of what the YouTube sharing request says (presuming it says something originating from "MediaWiki" or me)?

Race condition! One moment.

@Dzahn it's unclear if that's the same request; in fact in the YouTube administrator interface the request had been submitted as https://mediawiki.org/. There's nothing in the UI or URLs of YouTube or G+ suggesting that was the request generated, unfortunately (it's very nondescript).

Is there any other extended or I guess additional general information included for that request?

If we can't conclusively identify that request as from the official MediaWiki YouTube account, I wouldn't accept that request.

One other approach we might try is updating the YouTube account so that noc@ can become a manager of it, then you could go to the YouTube settings page to try to authorize the change (a DNS TXT record update will likely be required, although I can't say for certain).

Yet another option might be if I submit a patch with an additional TXT record using a verification code generated from my own abaso@ console, although I don't know if Google's parser will realize there are two TXT records having the same format but different key-value pairs. My understanding is that doesn't work so well for SPF, I'm just not sure about site verifications outside of SPF.

What do you think we should try?

Dzahn added a comment.Apr 6 2017, 7:45 PM

@Dzahn it's unclear if that's the same request; in fact in the YouTube administrator interface the request had been submitted as https://mediawiki.org/.

Weird, that's the only one of the 4 combinations that actually has "No new messages or recent critical issues."

Is there any other extended or I guess additional general information included for that request?

No, there is just that line and a short text like "Google has identified that mediawiki-0794@pages.plusgoogle.com has sent you a request to link https://www.mediawiki.org/ to the MediaWiki YouTube channel. If your site is linked to the YouTube channel, that can improve the channel's visibility on YouTube Search. " no further information about the source of the request.

If we can't conclusively identify that request as from the official MediaWiki YouTube account, I wouldn't accept that request.

Yea, not doing it. It just looks like of the other "spam" messages then.

One other approach we might try is updating the YouTube account so that noc@ can become a manager of it

I would try to avoid that. The trend should be to delegate things away from noc@ rather than adding more to it.

Yet another option might be if I submit a patch with an additional TXT record using a verification code generated from my own abaso@ console
I don't know if Google's parser will realize there are two TXT records having the same format but different key-value pairs. My understanding is that doesn't work so well for SPF, I'm just not sure about site verifications outside of SPF.

I have no idea either. We should find out what the actual problem is. Does it say anything to indicate the current TXT record is not ok? That it fails validating?

What do you think we should try?

I think contact Google to find out why a delegated account with full access still can't read messages and approve such requests, since that seems to be the whole point of delegating.

One other approach we might try is updating the YouTube account so that noc@ can become a manager of it

I would try to avoid that. The trend should be to delegate things away from noc@ rather than adding more to it.
I have no idea either. We should find out what the actual problem is. Does it say anything to indicate the current TXT record is not ok? That it fails validating?

The YouTube UI actually provides a link to have one go in and validate - https://www.google.com/webmasters/verification/verification?siteUrl=https%3A%2F%2Fmediawiki.org%2F. That thing, just by the way it works, The problem is, I think, that because I'm logged in as abaso@ while I do this, the Search Console at that URL naturally generates a code I could use

What happens when as noc@ you go to https://www.google.com/webmasters/verification/details?hl=en&domain=mediawiki.org ? Does that show it's delegated to abaso@ ?

In Webmaster Central at https://www.google.com/webmasters/verification/home?hl=en, only "wikipedia.org" shows as being delegated (plus some other app identifiers). mediawiki.org isn't listed in there. Do you see me delegated if you start from there?

Dzahn added a comment.EditedApr 6 2017, 9:31 PM

following https://www.google.com/webmasters/verification/verification?siteUrl=https%3A%2F%2Fmediawiki.org%2F as noc@ gets me "You are already a verified owner of https://mediawiki.org/. Verifying with more than one method will make your ownership more resilient."

following https://www.google.com/webmasters/verification/details?hl=en&domain=mediawiki.org gets me "You are currently a verified owner of mediawiki.org. Verified using these methods: DNS TXT record Details:

https://www.google.com/webmasters/verification/details?hl=en&domain=wikipedia.org says:

Verification attempts
Date Email Result Method
2 years ago
3/25/15 12:07:28 AM UTC abaso@wikimedia.org Reverification succeeded. Delegation

https://www.google.com/webmasters/verification/details?hl=en&domain=mediawiki.org did NOT show you.

I added you on that screen. Now i see:

Verification attempts
Date Email Result Method
Less than a minute ago
4/6/17 9:29:28 PM UTC abaso@wikimedia.org Ownership was delegated by noc@wikimedia.org. Delegation

So i think that was the solution and the answer to all that is that delegation in Webmaster Central is separate from delegation in Search Console.

That did the trick. Thanks!

Dzahn closed this task as Resolved.Apr 7 2017, 6:17 PM
Dzahn claimed this task.

ok, cool :) thanks for confirming and your patience. resolving ticket

Thank you as well for your patience. I forgot about that delegation distinction (assuming there has always been one) !