Page MenuHomePhabricator

Weekly report for Automatic editing suggestions and feedbacks for articles in Wiki Ed Dashboard
Closed, ResolvedPublic

Description

Project Synopsis

The Wiki Ed Dashboard / Programs & Events Dashboard is a Ruby on Rails + Javascript application that helps people organize groups of newcomers to contribute to Wikipedia. This project aims to use ORES (Objective Revision Evaluation Service) to provide specific useful editing suggestions to newcomers about how they can improve existing Wikipedia articles or article drafts they are working on. This can give an idea of what kind of improvements are needed for the article and gives them a jumpstart in their contributions

Final Summary

  • After the project, an Automatic feedback feature is successfully included in the Wiki-Ed dashboard that is shown in the MyArticles component that shows the articles edited by a particular user and also shows them in the Articles Edited Section for the suggestion to be reviewed by instructors.
  • There is a feature for users to add their own suggestions on the edits in addition to the Automatic Feedback.
  • Adding an easy way for users to give feedback on this feature.
  • Even if the Automatic Suggestions couldn’t be made smarter as part of my project I hope the work done to document the ORES features would encourage such improvements.
  • Making a spreadsheet of the ORES suggestions pointed to some blatant errors in ORES predictions due to redirects and the issue is notified in this task.

Next Steps

  • I couldn’t contribute to making the Automatic Suggestions smarter as I lacked some experience with Wikipedia Editing and this is a major scope of improvement for the project.
  • Adding the feature for custom user suggestions on the edits in the Article-Viewer component where it could be more relevant.
TimelineTaskRemarksWork reportStatus
Week 1 (Due May 18)Community Bonding periodFirst Blog postDone
Week 2 (Due May 25)Community Bonding periodIntroduced myself to the community through mailing list. Joined Zulip. Discussed with mentors about participation during GSoC. Learning new technologies for the project.Week 2 - Blog PostDone
Week 3 (Due June 1)Community Bonding periodUpdated deliverables. Did some research on the dashboard and finalized the goals of the project.Week 3 - Blog postDone
Week 4 (Due June 8)Design and add buttons in the MyArticles component that would display the feedbackThe feedback buttons will be a way for users to say how each and every aspect of the suggestion was useful and would be designed in a more sophisticated manner in the future.Blog postDone
Week 5 (Due June 15)Add feedback based on ORES featuresThe features are retrieved and processed in the rails backend to generate feedback. They are not stored in the backend as of now. They are retrieved in the frontend through Redux. The features based feedback should be improved.Blog postDone
Week 6 (Due June 22)Add feedback based on ORES ratingThe ORES predicted rating is retrieved from the ORES API and was displayed in the frontendBlog postDone
Week 7 (Due June 29)Improve Feedback messagesThe feedback messages are improved and design for displaying it improvedBlog postDone
Week 8 (Due July 6)Extend the feedback feature to Sandbox articles and add feedback button to Assigned Articles component.Extended the feedback feature to sandbox articles. Improved the suggestions to give the users a hint on the Wikipedia Assessment Scale. Added a way to receive suggestions from the users within the modal.Blog postDone
Week 9 (Due July 13)Improve the feedback for further testing. Ideation to improve automatic feedback.An open Excel Sheet to get some resources and all hands on improving the automatic feedbackBlog postDone
Week 10 & 11(Due July 27)Add Custom Feedback FeatureUsers can add a feedback to an article in addition to the existing automatic feedbackBlog postDone
Week 12(Due August 3)Improve the custom feedback featureAdded user reference to feedback. Added delete functionality. Finalized project deliverables with mentorDone
Week 13 (Due August 10)Merging the Custom Feedback FeatureSwitched the feedback flow to a design that does not confuse between automatic feedback and user feedbackDone
August 10 to August 21Identify areas of improvement in ORES. Write documentationMaking a spreadsheet of the ORES suggestions pointed to some blatant errors in ORES predictions due to redirects and the issue is notified in this taskDone
Final WeekSubmit Code and EvaluationsFinal PostDone

Event Timeline

Restricted Application added a subscriber: Base. · View Herald TranscriptMay 7 2017, 7:53 AM
Keer25 updated the task description. (Show Details)May 20 2017, 6:06 AM
Keer25 updated the task description. (Show Details)May 26 2017, 1:26 PM
Keer25 updated the task description. (Show Details)May 26 2017, 3:06 PM
Sek2016 added a subscriber: Sek2016.Jun 1 2017, 4:03 PM
Keer25 updated the task description. (Show Details)Jun 1 2017, 8:57 PM
Keer25 updated the task description. (Show Details)
Keer25 updated the task description. (Show Details)Jun 3 2017, 6:03 PM
Keer25 updated the task description. (Show Details)Jun 13 2017, 9:27 AM
Sumit added a comment.Jun 27 2017, 6:24 AM

Hi @Keer25 , please keep your weekly reports updated.

Keer25 updated the task description. (Show Details)Jun 27 2017, 11:30 AM
Keer25 updated the task description. (Show Details)Jun 29 2017, 7:18 PM
Keer25 updated the task description. (Show Details)
Keer25 updated the task description. (Show Details)Jul 5 2017, 7:13 AM
Keer25 updated the task description. (Show Details)Jul 5 2017, 8:11 AM
Keer25 updated the task description. (Show Details)Jul 18 2017, 12:55 AM
Keer25 updated the task description. (Show Details)Aug 1 2017, 10:49 AM
Keer25 updated the task description. (Show Details)Aug 9 2017, 8:36 PM
Keer25 updated the task description. (Show Details)Aug 9 2017, 8:46 PM
Keer25 updated the task description. (Show Details)Sep 1 2017, 1:28 PM
Keer25 updated the task description. (Show Details)Sep 1 2017, 2:18 PM

Hi! If there is not anything remaining in this task could you please resolve it?

srishakatux closed this task as Resolved.Sep 26 2017, 9:52 PM

I'm closing this task now, as I don't see anything remaining in this if you disagree, please feel free to re-open!