Page MenuHomePhabricator

Attempt FMIS default category on municipal level
Closed, ResolvedPublic4 Estimate Story Points

Description

When a specific commonscat does not exist for an archeological monument we should
attempt to use the correct subcategory of Archaeological_monuments_in_Sweden_by_municipality before falling back on "Län", "Landskap" or the top category.

For this we can use self.kommunName (note that not all images with fmis has a kommun).

  • Modifications to the default scheme of 'Category:Archaeological monuments in {kommunName} Municipality‎' will be needed for some municipalities.

Event Timeline

The following municipalities either do not have categories or they follow a different schema

0642 Mullsjö
2523 Gällivare
2510 Jokkmokk
1407 Öckerö
1060 Olofström
1781 Kristinehamn
1960 Kungsör
2584 Kiruna
2080 Falun
1465 Svenljunga
2521 Pajala
1737 Torsby
1490 Borås
1764 Grums
2506 Arjeplog
2580 Luleå
0114 Upplands-Väsby
1260 Bjuv
2581 Piteå
0617 Gnosjö
2582 Boden
1492 Åmål
1231 Burlöv
1447 Gullspång
2462 Vilhelmina
2023 Malung
0665 Vaggeryd
1462 Lilla Edet
0319 Älvkarleby
1439 Färgelanda
1962 Norberg
0687 Tranås
2514 Kalix
2061 Smedjebacken
1782 Filipstad
2082 Säter
0765 Älmhult
0980 Gotland
1315 Hylte
2421 Storuman
2031 Rättvik
0512 Ydre
1765 Årjäng
1783 Hagfors
2482 Skellefteå
2583 Haparanda
2518 Övertorneå
2505 Arvidsjaur

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:20 AM
Lokal_Profil set the point value for this task to 3.
Lokal_Profil changed the point value for this task from 3 to 4.
Lokal_Profil closed this task as Resolved.May 16 2017, 2:52 PM
Lokal_Profil claimed this task.

Merged: https://github.com/lokal-profil/upload_batches/commit/85c34cf0b5bbf69fcf03c35c97bb60ba4063eb0b

This was implemented in that we try for the category Archaeological monuments in {kommunName} Municipality‎ and failing that check Archaeological monuments in {kommunName}. If both fail we fall back on adding Province + County categories.

Lokal_Profil moved this task from to Review to Done on the User-LokalProfil board.May 16 2017, 2:52 PM