Page MenuHomePhabricator

mass adding of jakub-onderka/php-console-highlighter missed changes to composer.lock files
Closed, ResolvedPublic

Description

At least the AWSSDK repository now gives an composer.lock error, because the change rEAWK8a394dd0e82a39aa451fd1ba4aba1a1dc7fda974 only updates the composer.json, not the also commited composer.lock file.

20:00:25 + composer --ansi validate --no-check-publish
20:00:28 ./composer.json is valid, but with a few warnings
20:00:28 See https://getcomposer.org/doc/04-schema.md for details on the schema
20:00:28 The lock file is not up to date with the latest changes in composer.json, it is recommended that you run composer update.
20:00:28 No license specified, it is recommended to do so. For closed-source software you may use "proprietary" as license.

Please check all repositories with composer.lock file, if the lock file needs changes to unbreak CI

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 3:02 PM
Umherirrender renamed this task from mass adding of jakub-onderka/php-console-highlighter missed composer.lock files to change to mass adding of jakub-onderka/php-console-highlighter missed changes to composer.lock files.May 8 2017, 3:03 PM

Change 352603 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/AWSSDK@master] Remove committed vendor folder

https://gerrit.wikimedia.org/r/352603

hashar added a comment.May 8 2017, 7:21 PM

I have definitely havent updated composer.lock at all, sorry.

It seems the AWSSDK extension is meant to provide some dependencies that are available on packagist.org. Nowadays with MediaWiki supporting composer install of dependencies, I am not sure how needed that is. Maybe it can be dished out.

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

I have run composer validate locally on all extensions of mediawiki/extensions

The following repos are effected:

  • AWS
  • AWSSDK
  • Cards

Please fix the test runs there.

For information: DonationInterface is the last repo with php-lint missing jakub-onderka/php-console-highlighter.
It also have a composer.lock. Would be nice to see a patch set there. Thanks.

Change 354130 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/extensions/Cards@master] Delete outdated composer.lock

https://gerrit.wikimedia.org/r/354130

Change 354130 merged by jenkins-bot:
[mediawiki/extensions/Cards@master] Delete outdated composer.lock

https://gerrit.wikimedia.org/r/354130

Change 352603 merged by jenkins-bot:
[mediawiki/extensions/AWSSDK@master] Remove committed vendor folder

https://gerrit.wikimedia.org/r/352603

Change 357008 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/extensions/AWS@master] Delete outdated composer.lock

https://gerrit.wikimedia.org/r/357008

Change 357008 merged by jenkins-bot:
[mediawiki/extensions/AWS@master] Delete outdated composer.lock

https://gerrit.wikimedia.org/r/357008

hashar closed this task as Resolved.Jun 6 2017, 12:02 PM

AWSSDK should be emptied / archived. I have filled T167124 for that.

Looks like all repositories are fine now.