Page MenuHomePhabricator

W3C Validator complains about <dd> elements missing <dt> children, and some unknown "language" parameter values
Closed, DuplicatePublic

Event Timeline

Jidanni created this task.Jun 22 2017, 12:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2017, 12:52 PM
Aklapper renamed this task from Invalid HTML to W3C Validator complains about <dd> elements missing <dt> children, and some unknown "language" parameter values.Jun 22 2017, 1:37 PM
Aklapper edited projects, added MediaWiki-General; removed MediaWiki-HTML-Templating.

@Jidanni: This task mixes several problems - see https://www.mediawiki.org/wiki/How_to_report_a_bug :

  • The W3C website does not understand lang="gem-pro", lang="ine-pro", lang="simple". Which actual problem that you experience does that situation create?
  • <dl>s missing <dt>s.

It was the <dl>s missing <dt>s that was bothering me.

Izno added a subscriber: Izno.Dec 26 2017, 1:29 PM

The main issue described in this task is a duplicate of T6521: Colon (:) & semicolon (;) shouldn't output as HTML definition list when used for indentation, boldfacing. Is the other item an actual issue or should this be closed duplicate?

Izno added a comment.Dec 28 2017, 2:30 PM

I've merged the task because the rest of it is invalid. The reason the validator complains about the languages is because they are not valid language tags: -pro is not a valid language subtag and simple is not a valid language tag.

English Wikipedia is working on getting to valid language tags. You may wish to stop by template talk:Lang and ask about this.