Page MenuHomePhabricator

Create English namespace aliases for hiwikiversity
Closed, ResolvedPublic

Description

Per T168765#3514911.

Portal: प्रवेशद्वार:
School: विद्यालय:
Collection: संग्रह:

Event Timeline

Urbanecm created this task.Aug 10 2017, 6:07 AM
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 10 2017, 6:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as High priority.Aug 10 2017, 6:07 AM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptAug 10 2017, 6:07 AM

Sir please add topic namespace as well

Dereckson updated the task description. (Show Details)Aug 10 2017, 6:12 AM

Change 370990 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Create a few of namespace aliases for hiwikiversity

https://gerrit.wikimedia.org/r/370990

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.

Per T131754 and T133440, ne.wikibooks and hi.wikibooks use Subject: and not Topic: as namespace English alias for विषय:

@Jayprakash12345 what do you think to be coherent with hi.wikibooks to call the विषय: namespace Subject: instead of Topic: ?

That would allow to use Subject: alias without any bad title error.

Jayprakash12345 added a comment.EditedAug 10 2017, 7:12 AM

The Meaning of Topic are different. Its meaning outcome from Purposes:-
Topic - विषय (In An Education)
Topic- मुद्दा (In Political)

It is right Subject have also meaning विषय.

Sir, Now Drop the Topic namespace. As you early told me that it is not using on Eng wikiversity. They using Portal for it. So we will also use Portal for it instead of Topic.

Thank you

@Dereckson Sir, Are there any problem to merge patch.

Jayprakash12345 lowered the priority of this task from High to Low.Aug 12 2017, 5:53 PM

Nope, they arent. We were discussing about this privately and decided to do the deploy. As next deployment window will be at Monday, I'll use it.

Change 370990 merged by jenkins-bot:
[operations/mediawiki-config@master] Create a few of namespace aliases for hiwikiversity

https://gerrit.wikimedia.org/r/370990

Mentioned in SAL (#wikimedia-operations) [2017-08-15T23:12:39Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Create a few of namespace aliases for hiwikiversity (T172977) (duration: 00m 53s)

Jayprakash12345 closed this task as Resolved.Aug 16 2017, 2:04 AM

@Jayprakash12345: On which exact page (=link) are they not shown? Can you provide one example page (=link) that is "not shown"?
Exact steps to reproduce problems are welcome, see https://mediawiki.org/wiki/How_to_report_a_bug - thanks! :)

@Jayprakash12345: On which exact page (=link) are they not shown? Can you provide one example page (=link) that is "not shown"?
Exact steps to reproduce problems are welcome, see https://mediawiki.org/wiki/How_to_report_a_bug - thanks! :)

Sorry Sir, I Explain it more precisely.

I was made some pages on beta.wikiversity with prefix School: namespace. Now Hindi wikiversity are open. and pages are imported. But School: namespace are not redirecting on local namespace विद्यालय: . So this task had open to make alias. Now school: are redirecting विद्यालय. Which is good. But the pages which was imported. They all are disappeared. We can see them on main namespace (I provided link above). When I click on School:Page. It redirects on विद्यालय:Page. And I am seeing that Page are not exist.

Here two problem arise.

  1. School:Pages are currently in main namespace. So someone click Random Pages. They comes.
  2. Where the School:pages are gone. When we open School:Pages It will redirect on विद्यालय:Pages .
Marostegui added a subscriber: Marostegui.EditedAug 18 2017, 11:04 AM

Hi,

What are we, DBAs, supposed to do here @Jayprakash12345?

@Marostegui Sir, who can check School:Pages in Database. Can you give me path?

Aklapper added a comment.EditedAug 18 2017, 11:38 AM

@Jayprakash12345: Again, please do provide specific test cases with full links, so someone else could reproduce the problem without any need for interpretation.

If I understand correctly, I go to https://hi.wikiversity.org/w/index.php?title=विशेष%3Aउपसर्ग+अनुसार+पृष्ठ&prefix=&namespace=0&hideredirects=1 and click e.g. on "School:इलेक्ट्रॉनिक्स" which links to https://hi.wikiversity.org/wiki/School:इलेक्ट्रॉनिक्स , but I end up on https://hi.wikiversity.org/wiki/विद्यालय:इलेक्ट्रॉनिक्स which is empty.

So the question is probably if the page School:इलेक्ट्रॉनिक्स (and its content) still exists but can currently not be reached in the browser, as you get redirected to विद्यालय:इलेक्ट्रॉनिक्स ? And how to fix that so the content can be reached in the browser?

And that pages starting with School: are still shown when searching in the main namespace?

Urbanecm added a comment.EditedAug 18 2017, 1:21 PM

Heff, I think I know what's the issue there (namespaceDupes.php required).

@Marostegui Nothing, from my POV.

@Urbanecm thanks, I don't really understand what I am asked to find out to be honest.

Mentioned in SAL (#wikimedia-operations) [2017-08-18T13:26:43Z] <Amir1> ladsgroup@terbium:~$ mwscript namespaceDupes.php --wiki=hiwikiversity (T172977)

Urbanecm closed this task as Resolved.Aug 18 2017, 1:29 PM

Fixed.

Thank you sir, Now it is working fine.