The pulsating blue dots of educational popups for links and citations are appearing misaligned for the toolbar inside Media and Reference dialog
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Trigger the NUE on your account
  2. Go to Insert>Media and select an image.

Observe that the pulsating blue dots of educational popups for links and citations are appearing misaligned inside the Media Settings dialog.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 24 2017, 11:55 PM
Deskana triaged this task as Normal priority.
Deskana added a project: Regression.
Deskana added a subscriber: matmarex.

Another OOUI-related problem? FYI @matmarex.

matmarex claimed this task.Aug 29 2017, 4:14 PM

This doesn't seem likely to be a recent regression… it's possible we just never noticed?

Looks like the problem is that the position of the dots is manually calculated, and for toolbars other than the main one this calculation happens before the toolbar is visible, so all the values come out as zero (placing the dot in the top left corner).

Change 374561 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] ve.ui.MWEducationPopupTool: Position blue dots with CSS only

https://gerrit.wikimedia.org/r/374561

Change 374561 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] ve.ui.MWEducationPopupTool: Position blue dots with CSS only

https://gerrit.wikimedia.org/r/374561

Deskana set the point value for this task to 1.Aug 30 2017, 6:48 PM
Deskana closed this task as Resolved.

Thanks @matmarex!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 30 2017, 6:48 PM
Ryasmeen edited projects, added Verified; removed Patch-For-Review.Aug 30 2017, 8:17 PM