Page MenuHomePhabricator

Requesting access to stat1005 for Slaporte
Closed, ResolvedPublicRequest

Description

Username: Slaporte
Full name: Stephen LaPorte

I need access stat1005 to take over some projects from @ZhouZ. I'm a Wikimedia Foundation employee with confidentiality obligations in my employment agreement. I've also signed L3! If you need to reach my manager, please send an email to Eileen at <ehershenov@wikimedia.org>, and copy me at <slaporte@wikimedia.org>. Happy to send anything else if it's helpful.

Thanks!

My public key is:

ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEArci9cR3XiDsHZ6KlagctW6ky/bPz3ArsNx621VhfGx9L+c/oNcU0tOAorjVQGrg0fSmaF45r/kOtyE5aE4wQY8mB7C8wCqzj9bWaeSwY54pmIAXwEyV50xiR1+MhFWSi7DolJGgRlUX21dztWNwX60SZEDQXoJNrhp091v5DeFRkI/0+84Yz8/F2PvPsh7fxKtdaK/427n6lO5eWtOhdHI9y6pIJ2wnygg1H70hsthRrWadXkyBr7hiMt+pvwGNHJIqC5cauQ6TgcvYd0fH+8Lxd7gZBBNb1S09HrUq94GY28U5x1gHI+SI3hpDYckRYy80ZZgzapftavPbCqAJlmw== stephen.laporte@gmail.com

Details

Related Gerrit Patches:

Event Timeline

Slaporte created this task.Sep 22 2017, 8:39 PM
Restricted Application added a project: Operations. · View Herald TranscriptSep 22 2017, 8:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Slaporte updated the task description. (Show Details)Sep 22 2017, 8:39 PM

I can confirm Stephen is taking over this.

hashar added a subscriber: hashar.Sep 22 2017, 9:14 PM

Note the public key is used on labs and IIRC access to production requires a different ssh key.

@Zoranzoki21 provided a patch in Gerrit at https://gerrit.wikimedia.org/r/#/c/379851/

Zoranzoki21 added a comment.EditedSep 22 2017, 9:32 PM

Note the public key is used on labs and IIRC access to production requires a different ssh key.
@Zoranzoki21 provided a patch in Gerrit at https://gerrit.wikimedia.org/r/#/c/379851/

Thank you for put link to patch in task.

Note the public key is used on labs and IIRC access to production requires a different ssh key.

Here is a different key:

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQDiyWuq/7N/dkVnEbiwfhmHjuSdMf3c1RxI0RwR3GGOW3mkLhQh4+EYPvsD81Eu2rdMujb6MLA2casflxUJc6CQmYat5cXocyAGwZzVYaysuRTEsY2oTS0ERHvuPT7swfXUsKirs6tulEYdX4bkf5qv7dUkddEw6h6QT10dKF4qgo/F4VcRJU7DMegsC9+ew3EbAs96LQMiDxRWtv1SFJuHjoFLNTV4FIJm+unfBrqnEyHRTR9shcR1Q0JIM0UH0R8K6opXOQsVYoExklxnTcuPIbvs7Fy36UEqYRyQP5Qpv5pgRUMVddAhs5YjvzaGTraApIb2/3HN7hRjHehpXYw9dlICz7NVhdQU8YWlI4yO83WvI3zVdrsogNx9Pg4EVLs9/ZBLp1wQTiDW8iitjZ7pwrng5CWao7PbUiA5SyBS9FZcjGgBCzTs1Og3Mydv6oHI7TbjhJlR1OoTEQApoF9OzL3NKDOkHxBxd5knDdPEzwh/o7VlPgnmKSnW/Yof+jIeaG4lsMmO1KFhXwQzNwSVX7Tm0nr/2dFOklXUcjTFxKAOwp0EYQ8u6BsuBPZkBVhigMxNCcUUHl7mLxKKtrGbWi8hxRxfHrrtD/m/PL7ZilQdZv/MzLUXSglvhJt9Hsb3SRBZ3YMrs99ahYpnAZu/tIHBMTbyf+bT9erq+M0Y9w== slaporte@wikimedia.org

Note the public key is used on labs and IIRC access to production requires a different ssh key.

Here is a different key:

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQDiyWuq/7N/dkVnEbiwfhmHjuSdMf3c1RxI0RwR3GGOW3mkLhQh4+EYPvsD81Eu2rdMujb6MLA2casflxUJc6CQmYat5cXocyAGwZzVYaysuRTEsY2oTS0ERHvuPT7swfXUsKirs6tulEYdX4bkf5qv7dUkddEw6h6QT10dKF4qgo/F4VcRJU7DMegsC9+ew3EbAs96LQMiDxRWtv1SFJuHjoFLNTV4FIJm+unfBrqnEyHRTR9shcR1Q0JIM0UH0R8K6opXOQsVYoExklxnTcuPIbvs7Fy36UEqYRyQP5Qpv5pgRUMVddAhs5YjvzaGTraApIb2/3HN7hRjHehpXYw9dlICz7NVhdQU8YWlI4yO83WvI3zVdrsogNx9Pg4EVLs9/ZBLp1wQTiDW8iitjZ7pwrng5CWao7PbUiA5SyBS9FZcjGgBCzTs1Og3Mydv6oHI7TbjhJlR1OoTEQApoF9OzL3NKDOkHxBxd5knDdPEzwh/o7VlPgnmKSnW/Yof+jIeaG4lsMmO1KFhXwQzNwSVX7Tm0nr/2dFOklXUcjTFxKAOwp0EYQ8u6BsuBPZkBVhigMxNCcUUHl7mLxKKtrGbWi8hxRxfHrrtD/m/PL7ZilQdZv/MzLUXSglvhJt9Hsb3SRBZ3YMrs99ahYpnAZu/tIHBMTbyf+bT9erq+M0Y9w== slaporte@wikimedia.org

Changed

RobH removed Zoranzoki21 as the assignee of this task.Sep 23 2017, 1:14 AM
RobH added a subscriber: Zoranzoki21.
Dzahn added a subscriber: herron.Sep 25 2017, 6:07 PM
Zoranzoki21 triaged this task as Low priority.
Zoranzoki21 moved this task from Untriaged to 3 Business Day Wait on the SRE-Access-Requests board.

Change 379851 merged by Dzahn:
[operations/puppet@production] Access for Slaporte (Stephen LaPorte) to stat1005

https://gerrit.wikimedia.org/r/379851

Dzahn added a subscriber: Dzahn.Sep 28 2017, 4:17 PM

@Zoranzoki21 Thanks! Part 1 is merged. Feel free to add part 2 now that adds him to the right groups. This is just partially solved for now.

@Zoranzoki21 Thanks! Part 1 is merged. Feel free to add part 2 now that adds him to the right groups. This is just partially solved for now.

I do not know how to add part 2.. Can you or another user to work it because I no know how.

Change 381243 had a related patch set uploaded (by Herron; owner: Herron):
[operations/puppet@production] Add slaporte to group analytics-privatedata-users for stat1005 access

https://gerrit.wikimedia.org/r/381243

Change 381243 had a related patch set uploaded (by Herron; owner: Herron):
[operations/puppet@production] Add slaporte to group analytics-privatedata-users for stat1005 access
https://gerrit.wikimedia.org/r/381243

Thank you!

Change 381243 merged by Herron:
[operations/puppet@production] admin: Add slaporte to analytics-privatedata-users for stat1005 access

https://gerrit.wikimedia.org/r/381243

! In T176518#3643715, @Zoranzoki21 wrote:
Thank you!

No problem :)

@Slaporte you should now be able to access stat1005

stat1005:~$ id slaporte
uid=2409(slaporte) gid=500(wikidev) groups=500(wikidev),731(analytics-privatedata-users)
Slaporte closed this task as Resolved.Sep 28 2017, 6:46 PM

Thanks, working great!