Page MenuHomePhabricator

Same search result listed twice in same query
Closed, ResolvedPublic

Description

If you make a search on Commons for nadja hirsch (link: https://commons.wikimedia.org/w/index.php?search=nadja+hirsch&title=Special:Search&go=Go) you will get the following result:


The result Category:Nadja Hirsch is listed twice after each other. This must be a bug/glitch, since why does the same result appear more than once in a search query?

Event Timeline

Restricted Application added projects: Discovery, Discovery-Search. · View Herald TranscriptSep 25 2017, 11:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
debt assigned this task to EBernhardson.Sep 28 2017, 5:12 PM
debt triaged this task as Normal priority.
debt edited projects, added Discovery-Search (Current work); removed Discovery-Search.
debt added a subscriber: debt.

It looks like the update for this category (currently in two indexes) hasn't gone through it's update. We'll try to update this manually, but in general, this process can take up to two weeks to completely regenerate.

Category moves have completed, not seeing duplicates anymore.

Cause and effect is not the same - this single example is fixed, but the fact that such an update may cause the same result to appear twice, seems like a bad underlying cause/problem.

the problem is simply moving results between indexes, while the move is underway there will be duplicates. There is no nice way to move 10's of millions of documents atomically.

debt closed this task as Resolved.Oct 2 2017, 2:07 PM