Page MenuHomePhabricator

Warning: Unknown variable: '::port_fragment'.
Closed, InvalidPublic

Description

> default: Warning: Unknown variable: '::port_fragment'. at /vagrant/puppet/modules/mediawiki/manifests/wiki.pp:103:77

Using stretch-migration branch (puppet4).

Event Timeline

Paladox created this task.Dec 16 2017, 10:53 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 16 2017, 10:53 PM

@Paladox do you have steps to recreate this? Can you reproduce it with a clean checkout of MediaWiki-Vagrant when provisioning a VM for the first time?

@bd808 hi, yes.

On gerrit-test3.

Hmm i doin't see this any more.

i do see ==> default: mesg: ttyname failed: Inappropriate ioctl for device though

bd808 closed this task as Invalid.Dec 18 2017, 12:12 AM

Hmm i doin't see this any more.

i do see ==> default: mesg: ttyname failed: Inappropriate ioctl for device though

That one happens on first boot of every VM. It happens because the root user's .profile contains mesg n to turn off wall/write access from other shells, but that command exits with the "mesg: ttyname failed: Inappropriate ioctl for device" error when the shell is not interactive. We have a bit of config in the ::misc module that adds a guard to stop it after Puppet has run for the first time in the VM.