Page MenuHomePhabricator

Invisible character at end of line through copy&paste
Open, NormalPublic

Description

Whenever I copy & paste text (paragraphs or words) within the editor or from somewhere outside, I get an invisible character at the end of each line/paragraph. When saving my edits, the character fortunately vanishes, but it is very annoying when you always have to double press delete in order to reach the actual end character of a line/paragraph. Especially when editing data in block-style templates (2017WikitextEditor), the constant double delete gets on my nerves and is the cause of a lot of typos.

My browser (Chromium, btw) tells me that the character is actually an image (?), namely

<img class="ve-ce-chimera ve-ce-chimera-webkit">

Hope that someone can fix this!

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 23 2018, 6:16 PM
Deskana changed the task status from Open to Stalled.Jan 25 2018, 12:58 AM
Deskana added a subscriber: Deskana.

I am unable to reproduce this problem. There are a lot bugs relating to copying and pasting which are depending on your browser and operating system combination, so I'm not that surprised I can't reproduce it. Please provide reproduction steps that are as precise as you can make them, as well as the versions of your browser and operating system.

Okay, did some testing: I can always reproduce the problem in Firefox and Chrome, while in Edge it works fine (all browsers are updated to the latest version). Whether I am logged in or not does not matter; any time I paste a chunk of text (no difference between VE and NWE), there is an invisible character at the end of the line, which I can only get rid off by deleting it explicitly or by saving the page. OS is Win10, also latest version.

Okay, it seems to be resolved, I can't reproduce it anymore!

Deskana closed this task as Resolved.May 16 2018, 9:09 AM
Deskana claimed this task.
Deskana triaged this task as Normal priority.

I guess we fixed at some point then. Great!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 16 2018, 9:09 AM

Oh no, seems like I overlooked something last night. :| The bug is still here, just reproduced it again. However I'd be glad if someone else could reproduce as well, otherwise I get the feeling I'm doing something wrong here, and I have no idea what that could be ...

matmarex reopened this task as Open.May 16 2018, 2:38 PM
matmarex removed Deskana as the assignee of this task.
matmarex added a subscriber: matmarex.

Sounds related to T188837 or T162916.