Page MenuHomePhabricator

Diff view sometimes displays string at the end which is actually at the beginning
Closed, InvalidPublic

Description

As you can see in image, added text:
* Plānots pabeigt "[[Rail Baltica]]" atzara celtniecību 4,4 kilometru garam dzelzceļa savienojumam ar [[Rīgas starptautiskā lidosta|lidostu "Rīga"]].
shows up in diff as
[[Rail Baltica]]" atzara celtniecību 4,4 kilometru garam dzelzceļa savienojumam ar [[Rīgas starptautiskā lidosta|lidostu "Rīga"]].* Plānots pabeigt "

with * Plānots pabeigt " moving from start to end. It doesn't happen all the time, but more than user would expect :)

Seen this in (more or less the latest) Firefox, not sure about other browsers.

Edit in question

have seen for different type of edits - but probably all(?) of them where in line, where there is *.

Most probbaly this is already tracked, so sorry for dublicate. And sorry for not adding tags, not sure, which are appropriate.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2018, 2:20 PM

Cannot reproduce

As I already said, it happens only SOMETIMES, not always. On that diff refresh (10 times), I got 4 messed-up diffs and 6 good diffs.

I do not manage to reproduce at all, no matter how often I reload that page (and bypass the browser cache)...
Do you have any non-default gadgets enabled? Does that also happen when not being logged in (private browser window)?

Aklapper renamed this task from Diff view messes up diffs (sometimes) to Diff view sometimes displays string at the end which is actually at the beginning.Mar 22 2018, 11:17 AM
Edgars2007 closed this task as Invalid.Apr 14 2018, 3:41 PM

Sorry for late response.

Yes, you're probably right. It's probably bug in cleanDiff.js.

Sorry.