Page MenuHomePhabricator

External link icon is cut off in the "Insert link" box
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Open any page in the source editor (for example, https://en.wikipedia.org/w/index.php?title=Moonlight_(2016_film)&action=edit )
  2. Click on the link icon in the toolbar to open the "Insert link" box
  3. Click on the radio button labelled "To an external web page"
Expected

The external link icon to the right of "Target page or URL" should be shown in its entirety.

Actual

The external link icon is cut off.


Event Timeline

Srdjan_m created this task.May 1 2018, 10:54 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2018, 10:54 AM

Thanks for reporting this.
Seems to be defined in WikiEditor:

#wikieditor-toolbar-link-int-target-status-external {
	padding-left: 30px;
	background-position: 0 50%;
	background-repeat: no-repeat;
	.background-image('images/dialogs/insert-link-external.png');
	background-position: left;
}
Vvjjkkii renamed this task from External link icon is cut off in the "Insert link" box to vwdaaaaaaa.Jul 1 2018, 1:13 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from vwdaaaaaaa to External link icon is cut off in the "Insert link" box.Jul 1 2018, 1:49 PM
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.Jul 3 2018, 1:53 AM

Change 473634 had a related patch set uploaded (by TheDJ; owner: TheDJ):
[mediawiki/extensions/WikiEditor@master] LinkDialog: fix size of background image

https://gerrit.wikimedia.org/r/473634

Change 473634 merged by jenkins-bot:
[mediawiki/extensions/WikiEditor@master] LinkDialog: fix size of background image

https://gerrit.wikimedia.org/r/473634

matmarex closed this task as Resolved.Nov 14 2018, 11:12 PM
matmarex assigned this task to TheDJ.
matmarex removed a project: Patch-For-Review.
TheDJ moved this task from Backlog to Closed on the WikiEditor board.Nov 27 2018, 1:47 PM