Page MenuHomePhabricator

Remove the "Edit source" and "Edit" buttons for blocked users
Closed, DuplicatePublic

Description

It's actually kind of irritating for a blocked user to see "Edit" buttons on pages that they're not allowed to (banned from) editing, it would be handier if the same cookie that handles cookie-block would remove the visibility of these buttons and simply replace them with "View source" so they could be copied to Wiki's where they're not blocked. Otherwise it could be seen as a big taunt against blocked users basically telling them "Hey, edit this page! Haha, not you.".

Event Timeline

DonTrung created this task.Jun 3 2018, 8:21 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 3 2018, 8:21 AM

Checking for blocks is a relatively expensive operation (it's a separate database query, plus potentially inserting a new block in case of autoblocks, plus potentially clearing the block if it expired), and therefore we do not do this unless necessary (i.e. when actually attempting to edit) to improve the performance in the common case where the user is not blocked. This is a duplicate of T7106.

Vvjjkkii renamed this task from Remove the "Edit source" and "Edit" buttons for blocked users to qrbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot lowered the priority of this task from High to Low.
CommunityTechBot closed this task as a duplicate.
CommunityTechBot renamed this task from qrbaaaaaaa to Remove the "Edit source" and "Edit" buttons for blocked users.
CommunityTechBot added a subscriber: Aklapper.