Page MenuHomePhabricator

Edit window of transclusion template doesn't show edits of transcluded page section
Closed, InvalidPublic

Description

Steps to Reproduce:

  1. Go to https://en.wikipedia.org/wiki/Talk:Noah%27s_Ark#Not_Neutral,_and_bullying... with Firefox Version 56.0.2 (64- bit) or Chrome Version 67.0.3396.87 (Official Build) (64-bit) (latest update at the time of this writing).
  2. Make sure you are logged in.
  3. Make sure you are in the section titled "Myth vs account or story controversy".
  4. Next to the transclusion template, click "edit" to get to https://en.wikipedia.org/w/index.php?title=Wikipedia:Help_Desk&action=edit#Not_Neutral,_and_bullying...
  5. The edit window should appear.

Actual results:

Mostly Help:Cite errors appear.

Expected results:

Show transcluded text in edit window.

Other information that might be useful:

Make sure to click on the edit link next to the transclusion hatnote and not the other edit links.

Screenshot of edit window:

Update:

The bug might not be reproducible anymore in this case because the conditions changed. The source text of the transclusion was archived so I had to change the link in the transclusion template and now the edit link does point to the desired text.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 23 2018, 6:22 AM
Aklapper updated the task description. (Show Details)Jun 23 2018, 10:53 AM
Aklapper edited projects, added MediaWiki-Page-editing; removed MediaWiki-General.
Thinker78 updated the task description. (Show Details)Jun 25 2018, 11:15 PM
matmarex updated the task description. (Show Details)Jun 26 2018, 8:19 PM

I don't think there is a bug here, just confusing page names and contents on Wikipedia…

You originally transcluded the page "Wikipedia:Help Desk" (note the uppercase "D"), and that's where the "fake" edit link pointed. That page is a redirect to "Wikipedia:Help desk" (lowercase "d"), but also contains… a bunch of very confused-looking comments about cite errors from 2014? which is what you saw in the edit window. https://en.wikipedia.org/w/index.php?title=Wikipedia:Help_Desk&redirect=no

The transclusion automatically follows the redirect, but since the edit link is manually generated by the template, it does not.

When you corrected the transclusion and link after the section was archived, you also fixed the "D" to "d": https://en.wikipedia.org/w/index.php?title=Talk:Noah%27s_Ark&diff=next&oldid=847378126

matmarex changed the task status from Open to Stalled.Jun 26 2018, 8:30 PM

@matmarex Greetings Earthling. If the confusion was capitalization of "d" then why only the edit window got confused and not the transclusion itself?

Vvjjkkii renamed this task from Edit window of transclusion template doesn't show edits of transcluded page section to cfaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii changed the task status from Stalled to Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
JJMC89 renamed this task from cfaaaaaaaa to Edit window of transclusion template doesn't show edits of transcluded page section.Jul 1 2018, 4:01 AM
JJMC89 changed the task status from Open to Stalled.
JJMC89 raised the priority of this task from High to Needs Triage.
JJMC89 updated the task description. (Show Details)

@Thinker78 Transcluding pages using {{...}} follows redirects automatically, the same as linking to them using [[...]]. This is what allows template redirects like https://en.wikipedia.org/w/index.php?title=Template:Fact&redirect=no to work.

However, editing pages (e.g. https://en.wikipedia.org/w/index.php?title=Template:Fact&action=edit) does not – if it followed redirects, it would be impossible to actually edit the contents of redirect pages.

matmarex closed this task as Invalid.Jul 2 2018, 5:50 PM
matmarex claimed this task.
CommunityTechBot reopened this task as Stalled.Jul 5 2018, 7:05 PM
MusikAnimal closed this task as Invalid.Jul 5 2018, 7:06 PM