Page MenuHomePhabricator

Encoded URLs not decoded when preloading the Duplicator extension
Closed, InvalidPublic

Description

Steps to reproduce:

  1. Create a page named Àccénts and insert some content
  2. Open http://examplewiki.com/wiki/Special:Duplicator?dest=A%C3%A7%C4%89ents&src=%C3%80cc%C3%A9nts (dest = Açĉents, src = Àccénts)
  3. Attempt to duplicate the page

Actual result:

  • An error is given because the URL encoded page name arguments are inserted in the form.

Expected result:

  • URL encoded arguments should be decoded prior to being used by the form.

Details

Related Gerrit Patches:

Event Timeline

Tinss created this task.Jul 12 2018, 6:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 12 2018, 6:22 AM

Change 445346 had a related patch set uploaded (by Antoine Mercier-Linteau; owner: Antoine Mercier-Linteau):
[mediawiki/extensions/Duplicator@master] Duplicator extension: decode form arguments passed through the URL

https://gerrit.wikimedia.org/r/445346

Tinss claimed this task.Jul 12 2018, 7:09 AM

Change 445346 abandoned by Antoine Mercier-Linteau:
Duplicator extension: decode form arguments passed through the URL

Reason:
Can no longer reproduce bug in MW 1.34

https://gerrit.wikimedia.org/r/445346

Tinss closed this task as Invalid.Feb 18 2020, 9:24 PM

I can no longer reproduce the bug in MediaWiki 1.34. This might have been due to a browser issue or something that has since been fixed in MediaWiki core.