Page MenuHomePhabricator

Multiple issues box icon does not always match contents which might be confusing
Closed, InvalidPublic

Description

When visiting
http://reading-web-staging.wmflabs.org/w/index.php/Musical_film

The banner displays like this

but upon expecting the overlay the 2 icons inside the issues do not match:

The problem stems from the fact that

  • sweep
    is a low issue
  • balance
    is a medium issue
  • we show the generic icon (in this case medium issue)

Developer notes

Showing the balance icon alongside "This article has multiple issues. Please help improve it or discuss these issues on the talk page." would be a little confusing

A few options

  • Update design to show all icons
  • Take the icon associated with the highest priority issue (in this case the balance icon) - possibly a little confusing.
  • Keep as is.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 21 2018, 12:09 AM
This comment was removed by Jdlrobson.

I did not initially notice that this is a medium issue. This is the expected behavior, imo:

  • Given a page with an issue with severity X and severity Y, if severity X > severity Y, we display the generic icon for severity X

The reasoning here is that the icons do not need to match the icons of the issues themselves, as displaying the icon for one issue but not the other may be misleading. Rather, the icons need to display the overall severity of the group of issues, which is the severity of the issue with highest level severity.

ovasileva triaged this task as High priority.Aug 21 2018, 8:33 AM

So this is working as expected?

ovasileva closed this task as Invalid.Aug 21 2018, 3:58 PM

Just needed confirmation for multiple cases. Confirmed the following:

Medium and low shows medium
Low and low shows low
Low and notice defaults to low

Couldn't find a sample for high and medium/low, but I think we can assume it will work based on the above. Closing this, but feel free to reopen if there's remaining concerns.