Page MenuHomePhabricator

Not working hooks "SpecialListusersHeaderForm" and "SpecialListusersHeader"
Closed, ResolvedPublic

Description

Not working hooks "SpecialListusersHeaderForm" and "SpecialListusersHeader" (tested on version 1.30 and 1.31). Changing the "out" variable does not add text to the Special:ListUsers page.

The problem occurs because of an error in the array names in the file UsersPager.php: https://doc.wikimedia.org/mediawiki-core/master/php/UsersPager_8php_source.html

In the lines 336 and 352 instead of the name of the array "$formDescriptor" used "$formDescript i or".

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2018, 4:09 PM

Thanks for reporting this and for taking a look at the code!

You are very welcome to use developer access to submit the proposed code changes as a Git branch directly into Gerrit which makes it easier to review them quickly. If you don't want to set up Git/Gerrit, you can also use the Gerrit Patch Uploader. Thanks again!

Restricted Application added a project: User-Jayprakash12345. · View Herald TranscriptAug 22 2018, 6:40 PM

Change 454624 had a related patch set uploaded (by Jayprakash12345; owner: Jayprakash12345):
[mediawiki/core@master] Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/454624

Umherirrender added a subscriber: Umherirrender.

Caused by https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/362872/ which is in REL1_30, REL1_31

Needs backporting? Adding the tags. Remove when not needed

Change 454624 merged by jenkins-bot:
[mediawiki/core@master] Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/454624

Change 456061 had a related patch set uploaded (by Legoktm; owner: Jayprakash12345):
[mediawiki/core@REL1_31] Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/456061

Change 456062 had a related patch set uploaded (by Legoktm; owner: Jayprakash12345):
[mediawiki/core@REL1_30] UsersPager: Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/456062

Change 456061 merged by jenkins-bot:
[mediawiki/core@REL1_31] UsersPager: Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/456061

Change 456062 merged by jenkins-bot:
[mediawiki/core@REL1_30] UsersPager: Fix typo in formDescriptor array

https://gerrit.wikimedia.org/r/456062

Legoktm closed this task as Resolved.Aug 29 2018, 2:37 AM