Page MenuHomePhabricator

CI fail in mediawiki/extensions/SemanticExpressiveness repository because of fail-archived-repositories
Closed, InvalidPublic

Description

Steps to reproduce

  1. Make patch in mediawiki/extensions/SemanticExpressiveness repository
  2. Let continuous-integration-infrastructure to run tests

Actual results
After few seconds from time of uploading patch, jenkins-bot will add message like this:

fail-archived-repositories https://integration.wikimedia.org/ci/job/fail-archived-repositories/140/console : This repository has been archived and new patches are not being accepted. If you want to maintain it follow https://www.mediawiki.org/wiki/Gerrit/Project_ownership#Requesting_repository_ownership and then change which jobs get run. in 0s

If is extension archived, repository have to be archived and locked.

Event Timeline

Restricted Application added subscribers: Dvorapa, Aklapper. · View Herald TranscriptAug 25 2018, 12:15 PM
Dvorapa removed a subscriber: Dvorapa.Aug 25 2018, 12:24 PM
MarcoAurelio closed this task as Invalid.Aug 25 2018, 12:24 PM
MarcoAurelio added a subscriber: MarcoAurelio.

This is one of the intances of T190671: Identify archived extensions on mediawiki.org but not on Gerrit (and viceversa).

https://www.mediawiki.org/wiki/Extension:Semantic_Expressiveness is marked as archived but the archival was not performed on Gerrit & friends. Archiving is being handled at T199417: Archive the Semantic Expressiveness extension.

Jenkins is behaving as expected so not a bug. Thanks.

This is one of the intances of T190671: Identify archived extensions on mediawiki.org but not on Gerrit (and viceversa).
https://www.mediawiki.org/wiki/Extension:Semantic_Expressiveness is marked as archived but the archival was not performed on Gerrit & friends. Archiving is being handled at T199417: Archive the Semantic Expressiveness extension.
Jenkins is behaving as expected so not a bug. Thanks.

Thanks @MarcoAurelio for reply and for merging of my patch. I know to Jenkins is behaving as expected, but I was confused and then I opened task.