Page MenuHomePhabricator

'Mark all changes as read' button cannot be clicked though there are changes
Closed, DeclinedPublic

Description

User:Misibacsi reported that Mark all changes as read does not work and mark changes as read, no matter how long the user waits. You can watch it here.

It is strange because it works if I use it, so there are the user's JS and CSS subpages just in case: link.

Event Timeline

Bencemac created this task.Sep 22 2018, 8:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 22 2018, 8:04 AM
Aklapper changed the task status from Open to Stalled.Sep 22 2018, 9:35 AM

Can Misibacsi please try again with safemode=1? This allows you to test if a problem is because of your user scripts or personal gadgets without uninstalling them. See https://www.mediawiki.org/wiki/Help:Locating_broken_scripts for more information.

Bencemac changed the task status from Stalled to Open.Sep 25 2018, 8:22 AM

Can Misibacsi please try again with safemode=1? This allows you to test if a problem is because of your user scripts or personal gadgets without uninstalling them. See https://www.mediawiki.org/wiki/Help:Locating_broken_scripts for more information.

We tried it with different browser (Firefox and Chrome), disabled add-ons and deleted JS/CSS pages. Other user reported the problem too, so something is wrong and should be fixed.

Does the problem also happen when using safemode=1 on Special:Watchlist?
If it does, please provide any non-default settings on https://hu.wikipedia.org/wiki/Speciális:Beállításaim#mw-prefsection-watchlist to reproduce.

Aklapper changed the task status from Open to Stalled.Sep 25 2018, 8:51 AM

Does the problem also happen when using safemode=1 on Special:Watchlist?
If it does, please provide any non-default settings on https://hu.wikipedia.org/wiki/Speciális:Beállításaim#mw-prefsection-watchlist to reproduce.

Yes, I forgot to mention that; we tried safemode=1 as well and it did not help.

I cannot reproduce with my watchlist on https://hu.wikipedia.org/w/index.php?hidepreviousrevisions=1&hidecategorization=1&hideWikibase=1&limit=250&days=30&title=Speciális:Figyelőlistám&debug=true&urlversion=2 :
The button Összes változtatás megjelölése olvasottként is active and can be clicked here.
Using Firefox 62 on Fedora.

Aklapper renamed this task from 'Mark all changes as read' does not work to 'Mark all changes as read' button cannot be clicked though there are changes.Sep 25 2018, 12:35 PM
Bencemac closed this task as Resolved.Oct 13 2018, 7:57 AM
Bencemac claimed this task.

@Aklapper Per reports of the affected users, the problem has been resolved this week, which means somebody fixed it (by accident?).

Aklapper changed the task status from Resolved to Declined.Oct 13 2018, 4:20 PM
Aklapper removed Bencemac as the assignee of this task.

Thanks for the update! Closing as declined as nobody cannot reproduce anymore and as it's unclear what was the reason / fix.