Page MenuHomePhabricator

Math calculations in infoboxes break horribly in VisualEditor source code previews
Closed, InvalidPublic

Description

The article at https://en.wikipedia.org/wiki/1729_(number) has an infobox on the side with a navigation row to jump between multiples of 1000. When I was trying to edit this article, I pressed the "Show preview" button in the source editor. This is what the preview looked like:

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 28 2018, 1:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Numbermaniac renamed this task from Rendering math in VisualEditor source code preview breaks horribly to Math calculations in infoboxes break horribly in VisualEditor source code previews.Oct 28 2018, 1:17 AM
Numbermaniac updated the task description. (Show Details)
Numbermaniac removed a project: VisualEditor.
Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 28 2018, 1:17 AM
TheDJ closed this task as Invalid.Oct 29 2018, 12:38 PM
TheDJ added a subscriber: TheDJ.

This page gives the exact same results in Special:ExpandTemplates. This indicates the problem is a wiki one, and not a VisualEditor one, the VE just happens to trigger it. I spent some time trying to figure out the template structure of this thing yesterday, but haven't yet finished my analysis. But since it is local issue, I think we can close this ticket as invalid.

TheDJ added a comment.Oct 29 2018, 4:22 PM

Note, this is due to Template:For nowiki, used by Template:Infobox_number/range.. not sure why there is a transclusion difference, this whole thing uses some magic subs and nowiki incantations, that probably shouldn't be relied upon, for exactly this reason.