Page MenuHomePhabricator

Admin who performs partial block cannot re-block the blocked user or other users
Closed, InvalidPublic

Description

An admin who blocks a user partially cannot change the block setting of the blocked user nor block other users, and receives the following message:

You cannot block or unblock other users because you are yourself blocked.

I, User:4nn1l2, partially-blocked User:4nn1l2test (my alternative account) on Test Wiki from editing a page for 2 hours. I also denied them from the ability of sending emails. Now, I myself cannot block other users nor re-block my alternative account.

Reproduction:

  1. Go to Test Wiki and make sure you have admin rights.
  2. Block a user (you can block mine, User:4nn1l2test) partially (Don't allow the blocked user to send emails).
  3. Try to block another user.
  4. You will be told "you cannot block or unblock other users because you are yourself blocked. "

Event Timeline

4nn1l2 created this task.Jan 22 2019, 5:24 PM
Restricted Application added subscribers: MGChecker, Aklapper. · View Herald TranscriptJan 22 2019, 5:24 PM
4nn1l2 closed this task as Resolved.Jan 22 2019, 7:32 PM
4nn1l2 claimed this task.

OK, I found out what had happened.

I had "Automatically block the last IP address used by this user, and any subsequent IP addresses they try to edit from" ticked, and therefore my own IP address was automatically blocked.

I will close this ticket.

Yeah, that checkbox can cause headaches during QA.

I was going to see if it was a version of T208965: Partially blocked admins should be able to access Special:Block, but thank you for coming back and marking it as resolved.

JJMC89 changed the task status from Resolved to Invalid.Jan 22 2019, 7:34 PM