Page MenuHomePhabricator

Editing Hiera namespace broken on wikitech for project admins with uppercase characters mid way through their name
Closed, ResolvedPublic

Event Timeline

Krenair created this task.Apr 23 2019, 12:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 23 2019, 12:25 PM

This blocks me removing deployment-ms-fe02 and deployment-poolcounter04 due to the references to those hosts on that page

bd808 renamed this task from Editing Hiera namespace broken on wikitech to Editing Hiera namespace broken on wikitech for project admins.Apr 23 2019, 2:53 PM
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Entering getUserDN  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Entering getDomain  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Created a regular filter: (cn:caseExactMatch:=andrew bogott)  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Entering getBaseDN  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Entering getDomain  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 basedn is ou=people,dc=wikimedia,dc=org  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Using base: ou=people,dc=wikimedia,dc=org  
2019-04-25 15:54:17 [XMHYKdBQmqAAAIR-PHIAAABO] labweb1001 labswiki 1.34.0-wmf.1 ldap INFO: 2.1.0 Couldn't find an entry

Change 506477 had a related patch set uploaded (by Alex Monk; owner: Alex Monk):
[mediawiki/extensions/OpenStackManager@master] Stop lowercasing all usernames for LDAP lookups

https://gerrit.wikimedia.org/r/506477

Krenair renamed this task from Editing Hiera namespace broken on wikitech for project admins to Editing Hiera namespace broken on wikitech for project admins with uppercase characters mid way through their name.Apr 25 2019, 4:05 PM

Change 506479 had a related patch set uploaded (by Andrew Bogott; owner: Andrew Bogott):
[mediawiki/extensions/OpenStackManager@master] Make usernames case-sensitive

https://gerrit.wikimedia.org/r/506479

Change 506482 had a related patch set uploaded (by Alex Monk; owner: Alex Monk):
[mediawiki/extensions/OpenStackManager@wmf/1.34.0-wmf.1] Stop lowercasing all usernames for LDAP lookups

https://gerrit.wikimedia.org/r/506482

Change 506479 abandoned by Andrew Bogott:
Make usernames case-sensitive

Reason:
This is a duplicate of Krenair's patch, already merged

https://gerrit.wikimedia.org/r/506479

Change 506477 merged by jenkins-bot:
[mediawiki/extensions/OpenStackManager@master] Stop lowercasing all usernames for LDAP lookups

https://gerrit.wikimedia.org/r/506477

Change 506482 merged by jenkins-bot:
[mediawiki/extensions/OpenStackManager@wmf/1.34.0-wmf.1] Stop lowercasing all usernames for LDAP lookups

https://gerrit.wikimedia.org/r/506482

bd808 assigned this task to Krenair.Apr 30 2019, 12:55 AM
Krenair closed this task as Resolved.Apr 30 2019, 12:55 AM