Page MenuHomePhabricator

Add anchor links for each section header
Closed, DuplicatePublic

Description

Along the lines of https://www.npmjs.com/package/anchor-js , I'd love to see Mediawiki section headers have a link (e.g., which showed up on hover over the section header) which would resolve to that heading, and allow one to bookmark or share the URL with the anchor added within it.

While there are browser add-ons (e.g., my own https://addons.mozilla.org/en-US/firefox/addon/jump-to-anchor/ ) that let people get the anchor link without digging into the source code, it would be very convenient for the average user who doesn't know about these add-ons to be able to get at this info and lead people to the precise section of interest.

Event Timeline

Brettz95 created this task.Jun 6 2019, 3:58 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 6 2019, 3:58 AM

@Brettz95 As you haven't provided a tag with your task, I'm assuming that you mean MediaWiki core heading structure. This has already been covered in T18691

Brettz95 closed this task as Invalid.Jun 6 2019, 4:15 AM

Thanks, I see it is a dupe of T18691

@Brettz95 : For future reference, please follow the structure in https://www.mediawiki.org/wiki/How_to_report_a_bug to avoid misinterpretation - thanks.