Page MenuHomePhabricator

Only make data bridge ResourceLoader modules available if data bridge is enabled
Closed, ResolvedPublic

Description

Originally part of the second Gerrit chain in T226494: Create configuration for matching regex: we probably don’t want to make the work-in-progress data bridge modules available in production. Currently, they’re defined anywhere, and the “enabled or not” setting only determines whether we load them by default or not.

Patch-For-Review:

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterbridge: conditionally load module

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2019, 11:52 AM

Change 519994 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] bridge: conditionally load module

https://gerrit.wikimedia.org/r/519994

Change 520255 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] bridge: add client-side warning for missing config

https://gerrit.wikimedia.org/r/520255

Lucas_Werkmeister_WMDE updated the task description. (Show Details)

Change 519994 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] bridge: conditionally load module

https://gerrit.wikimedia.org/r/519994

Pablo-WMDE updated the task description. (Show Details)Jul 3 2019, 5:01 PM
Pablo-WMDE moved this task from Peer Review to Done on the Wikidata-Bridge-Sprint-1 board.
Pablo-WMDE closed this task as Resolved.Jul 17 2019, 8:52 AM