Page MenuHomePhabricator

UploadWizard: property panel added via "Add statement" persists when you upload another image
Closed, ResolvedPublicBUG REPORT

Description

Steps to reproduce:

  • add a new image using UploadWizard
  • in the metadata step click the 'Add statement' button to create a new property panel
  • finish submitting the image
  • click 'Upload more files'
  • add a new image
  • in the metadata step the new property panel you created when uploading the last file will be there

Event Timeline

Cparle created this task.Jul 2 2019, 3:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 2 2019, 3:55 PM
Ramsey-WMF triaged this task as Medium priority.Jul 3 2019, 6:50 PM
Ramsey-WMF changed the subtype of this task from "Task" to "Bug Report".
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.
Cparle claimed this task.Jul 9 2019, 11:36 AM
Cparle moved this task from To Do to Doing on the Structured-Data-Team-Current-Work board.

Change 522056 had a related patch set uploaded (by Cparle; owner: Cparle):
[mediawiki/extensions/UploadWizard@master] Delete non-default properties from the DOM after submission

https://gerrit.wikimedia.org/r/522056

Change 522056 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Delete non-default properties from the DOM after submission

https://gerrit.wikimedia.org/r/522056

Just tested on production and the issue is still there. I wonder though...should we keep it? It could be seen as a convenience.

Ramsey-WMF closed this task as Resolved.Aug 7 2019, 11:04 PM

Fixed on production.