Page MenuHomePhabricator

Group-xxx.css is intermittently not loading
Closed, InvalidPublic

Description

The css data from MediaWiki:Group-sysop.css is intermittently not loading. This is causing some issues for sysops, as some elements that are only useful for sysops (but not 'harmful' for everyone else) are often hidden in common.css, with an override in the corresponding group-xxx.css files to !important-ly display the elements again.

Examples are in:

https://test.wikipedia.org/wiki/MediaWiki:common.css
https://test.wikipedia.org/wiki/MediaWiki:Group-sysop.css

With a sample test on testwiki, the rendered page says it knows the account is a sysop (in ,"wgUserGroups":["sysop","*","user","autoconfirmed"] ) however, the group-specific stylesheet is not linked to the document code.

See also discussion at: https://en.wikipedia.org/w/index.php?title=User_talk:Xaosflux&oldid=909681787#What's_broken?

Event Timeline

Xaosflux created this task.Aug 7 2019, 12:44 AM
Restricted Application added a project: Performance-Team. · View Herald TranscriptAug 7 2019, 12:44 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I've updated https://test.wikipedia.org/wiki/MediaWiki:Group-sysop.css to contain a simple example.

For me this seems to work on all regular pages (my account is a sysop on testwiki):

Does this work for you?

Krinkle changed the task status from Open to Stalled.Aug 7 2019, 2:36 PM
Krinkle moved this task from Inbox to Backlog on the MediaWiki-ResourceLoader board.

@Krinkle ok that is executing, so there must be something else going on. The specific symtom we're seeing is that the "page notice" edit links introduced in https://test.wikipedia.org/wiki/MediaWiki:Editnotice-0 via https://test.wikipedia.org/wiki/Template:Editnotice are not appearing for some users. With my normal account (xaosflux) I see them, while other sysop accounts are not (e.g. SilkTork, Xaosflux2)

Can you use the browser's developer tools to inspect a nearby element that should be visible or invisible, and then find it in the inspector, and look at which styles are loaded for it?

For example, here I inspect the styles for the logo. The sidebar area with the CSS rules like #p-logo is the one I would like to see.

Is the specific element that we're seeing the problem with. It is not present at all in the source when it is not displayed.

Here is the computed rule for it:

When it is missing, it is not anywhere in the HTML elements tree? If so, then the issue is likely not related to ResourceLoader or CSS. But rather it could mean that the editnotice wikitext or template is sometimes not producing the element.

I'm not sure what to do for the next step in troubleshooting, was able to replicate this with another account easily:

Krinkle closed this task as Invalid.EditedAug 7 2019, 7:59 PM

I'd recommend Tech forum, Wikitech or #wikimedia-tech (on Freenode IRC) for support with templates and gadgets.

I'll close this for now as the system appears to work without issue.